Bug 75206 - gnome-terminal uses some keys for gui instead of sending them to the tty
gnome-terminal uses some keys for gui instead of sending them to the tty
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: gnome-terminal (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-05 10:09 EDT by Hans de Goede
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-05 10:09:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hans de Goede 2002-10-05 10:09:12 EDT
Description of Problem:
gnome-terminal uses some keys for gui instead of sending them to the tty

Version-Release number of selected component (if applicable):
gnome-terminal-2.0.1-5

How Reproducible:
Start gnome terminal, start mc, try to quit (F10 key), or try to get help (F1 key)


Steps to Reproduce:
1. Start gnome-terminal
2. Start mc
3. press F1

Actual Results:
Gnome-help starts with gnome-terminal help

Expected Results:
mc helpscreen


Additional Information:
This is questionable but I consider this a bug, try getting help in ntsysv, mc,
vim, whatever or quitting from mc. I understand this is supposed to be a
feature, but I concider it to be a bug. Esp since it is on by default.
Comment 1 Havoc Pennington 2002-10-05 11:07:03 EDT
Edit->Keybindings and turn it off, that's what Edit->Keybindings is for.
gnome-terminal uses standard key shortcuts for apps, 
with the exception of adding "Shift" to some of them e.g. Ctrl+Shift+C

Help really should be the standard binding, since it's after all used for
getting help.
Comment 2 Hans de Goede 2002-10-05 11:18:44 EDT
Hmm, I don't agree with you, I don't want to play open bug-close bug, but could
you discuss this with the rest of the RH develop team. I've the feeling this
isn't as obvious a choice as you say it is.

BTW I never use gnome-terminal. I always use xterm. I always check all the terms
shipped with RH because some releases ago I've worked closely with RH to get all
the keybindings working as expected (home,end,del,bs etc).

And as such I'm worried that this will confuse some users.
Comment 3 Havoc Pennington 2002-10-05 12:26:02 EDT
It's been discussed a good bit, internally and on mailing lists.

It's always confusing to change something, sure, but the general approach we're
taking is that it's more important for apps to be consistent with each other
now, than for each app to be consistent with past versions of itself.
Comment 4 Miloslav Trmac 2002-10-05 17:06:36 EDT
Well, I'd turn this into an RFE: add text to the "title" page of gnome-terminal
help (or make a second title page for help got by F1), which shows where to
turn it off. This could make happy some users that don't feel like browsing
through all the dialogs ;-)

Note You need to log in before you can comment on or make changes to this bug.