Bug 75207 - keypad +-* aren't recognised as such anymore
Summary: keypad +-* aren't recognised as such anymore
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: vte (Show other bugs)
(Show other bugs)
Version: 8.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-05 14:14 UTC by Hans de Goede
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-29 13:58:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Hans de Goede 2002-10-05 14:14:47 UTC
Description of Problem:
keypad +-* aren't recognised as such anymore. Normally keypad keys can be seen
as seperate keys from the normal +-* by an text mode application running in the
terminal, if the application has asked for them to send special ESC-sequences.

This used to work fine in gnome1

Version-Release number of selected component (if applicable):
gnome-terminal-2.0.1-5

How Reproducible:
Start gnome terminal, start mc, go to learn keys press the + on the keypad, it
isn't recognised. This used to work in gnome-terminal from gnome1, and it works
fine in xterm.

Steps to Reproduce:
1. Start gnome-terminal
2. Start mc
3. Goto learn keys (in the options menu, press F9 to get in the menu)
4. press + on the keypad.

Actual Results:
Nothing happens

Expected Results:
+ on keypad gets marked OK (try F1 - F12, etc)

Additional Information:

Comment 1 Hans de Goede 2002-10-05 14:30:13 UTC
I did some digging (in my memory and in the manpage for terminfo) The problem is
that gnome-terminal doesn't honer the smkx terminfo capability anymore (it used
todo so)

Other (better?) way to reproduce:
1) start xterm
2) type CTRL-V (this give the verbatim output of the next key even if it is an 
   esc-sequence, try for example CTRL-v F1
3) type + on keypad it gives "+" as output
4) type "tput smkx" <enter> (this enables the keypad transmit ability of the 
   terminal)
5) now do CTRL-V, + on keypad
6) you can make your + on keypad normal again by typing "tput rmkx"


p.s. konsole has this problem too, but there it can't be fixed because qt
doesn't know the difference between keypad and normal keys.


Comment 2 Nalin Dahyabhai 2002-10-14 21:40:28 UTC
Fixing in 0.9.2 and later.  Thanks!

Comment 3 Hans de Goede 2002-12-29 13:58:17 UTC
Fixed in phoebe, thanks closing with resolution rawhide


Note You need to log in before you can comment on or make changes to this bug.