Bug 75210 - httpd service doesn't restart when 2 ports are defined (ex: 80 & 8080)
httpd service doesn't restart when 2 ports are defined (ex: 80 & 8080)
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-httpd (Show other bugs)
8.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
Brian Brock
:
: 81092 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-05 10:39 EDT by Yannick Haineault
Modified: 2015-03-04 20:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-06 09:53:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yannick Haineault 2002-10-05 10:39:43 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
In the Apache configuration tool on Gnome, I add another port (8080) and this
message appears when I restart httpd:

Starting httpd: Syntax error on line 176 of /etc/httpd/conf/httpd.conf:
Listen takes one argument, A port number or a numeric IP address and a port number

Line 176 on my httpd.conf is: Listen *:8080 *:80

The version of httpd is httpd-2.0.40-8

This was working with Red Hat 7.3

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Specify another port on Apache configuration tool
2.restart hhtpd with user root: service httpd restart
3.Look at the error message (and cry!!!)
	

Actual Results:  I get this error message:


Starting httpd: Syntax error on line 176 of /etc/httpd/conf/httpd.conf:
Listen takes one argument, A port number or a numeric IP address and a port number

Expected Results:  Starting httpd:   [  OK  ]

Additional info:
Comment 1 Yannick Haineault 2002-10-05 12:55:36 EDT
If I manually configure the file /etc/httpd/conf/httpd.conf and add a new line 
for the second port, it works.

Example:
Apache configuration tool create this entry in httpd.conf:
Listen: *:80 *:8080

I replace this line by:
Listen: *:80
Listen: *:8080

and it works.  The problem seems to be at the Apache Configuration tool level.
Comment 2 Joe Orton 2003-01-13 12:44:32 EST
*** Bug 81092 has been marked as a duplicate of this bug. ***
Comment 3 Phil Knirsch 2003-02-06 09:53:42 EST
Fixed in CVS, rawhide package comming soon.

Read ya, Phil

Note You need to log in before you can comment on or make changes to this bug.