Bug 75211 - gnome terminal eats memory
Summary: gnome terminal eats memory
Status: CLOSED DUPLICATE of bug 74748
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: vte   
(Show other bugs)
Version: 8.0
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-05 15:17 UTC by Kris Buytaert
Modified: 2006-02-21 18:49 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:49:45 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Kris Buytaert 2002-10-05 15:17:33 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020916

Description of problem:
I installed RH 8.0 on a Dell x200 as test enivornment.  While working I
experienced my gnome-terminals dissapearing at random whilst freezing my  
machine for a couple of seconds before.  Closer examination shows that
gnome-terminal eats up my memory.  Even while I'm not doing any work in it.  I
switched to using xterm for working and running top to and leaving an idle
gnome-terminal open .  During the time I wrote this part it grew from 18M to 21M
...   It usually starts around 10Mb usage and I saw an instance running with
over 160Mb in use.




Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Ok so I tried reproducting it once.. 
1.booted clean machine,  started gnome terminal empty and xterm to run top

2. gnome terminal starts out on about  11064 used. 
3. waited a couple of seconds .. stayed on the same..memory usage.
then I ran some commands, ls , top, watch ls etc.. and after it's first activity
it started growing .  

Then I started running top in the gnome-terminal.  Within 60 seconds, memory
usages goes up to 100Mb ...
2 minutes later gnome-terminal uses over 200 Mb of ram.


	

Actual Results:  The acutal result is basically a denial of service "attack"

gnome-terminal keeps growing untill there is no memory left. It uses up all the
swap.  


Additional info:

Comment 1 Radek Hladik 2002-10-17 17:11:49 UTC
I'm expiriencing the same problem with gedit and other programs. When I start
gedit it takes about 20MB of RAM. After half an hour it allocates 450MB,
gnome-panel cca 70MB, etc... I have standard instalation of RH8.0 with only
Sawfish instead of metacity on Celeron 1.1, 256MB (Acer TravelMate 223)

Comment 2 Nalin Dahyabhai 2002-10-17 22:25:09 UTC
If you run "xdpyinfo", is RENDER one of the listed extensions?

Comment 3 Radek Hladik 2002-10-17 22:44:21 UTC
No xdypinfo | grep -i RENDER returns nothing. I forget to mention that I had to
switch off DRI as my videocard (intel 830m) didn't like to swich between
text(even frambuffer) and graphical consoles with DRI on.

Comment 4 Kris Buytaert 2002-10-28 22:50:31 UTC
No problem with DRI here as far as I know .. 
However the 830i issue could be related.

I`ll have to check that at the office tomorrow where I have 2 RH boxen with 830i
cards.


Comment 5 Kris Buytaert 2002-10-29 16:01:38 UTC
Just checked the 2 RH 8.0 machines and they are both i810, not 830.

Comment 6 Ray Strode [halfline] 2004-06-15 18:13:01 UTC
This appears to be a duplicate of bug 74748.  If you are still having
problems please bring it up there. Thanks.

*** This bug has been marked as a duplicate of 74748 ***

Comment 7 Red Hat Bugzilla 2006-02-21 18:49:45 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.