Bug 75214 - # of CPUs used for encoding only applied on restart
# of CPUs used for encoding only applied on restart
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: grip (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-05 11:41 EDT by Chris Ricker
Modified: 2014-03-16 22:31 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-04 18:09:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Ricker 2002-10-05 11:41:31 EDT
Grip has an option to specify the number of CPUs used for encoding (on the
Config -> MP3 -> Options screen; the field is labeled 'Number of CPUs to use')

Changes to this option are not applied until grip is exited and restarted
Comment 1 Chris Ricker 2002-10-05 11:52:50 EDT
Hmm, this *is* documented in the online help

file:///usr/share/gnome/help/grip/C/mp3config.html

This is confusing for users (or at least for me).  When I first ran grip, I
configured it, told it two CPUs, and happily starting ripping + encoding.  It
displayed one Rip progress meter and one MP3 (ie, encoding) progress meter.  I
assumed it was encoding using both CPUs, and just displaying a combined progress
output.

Later, I exited grip.  When I restarted grip, I discovered that it now displayed
one Rip progress meter and two MP3 (encoding) progress meters, and realized that
it had only been using one CPU the first time....

Perhaps this could be made more clear in the config screen by changing Config ->
MP3 -> Options

Number of CPUs to use

to 

Number of CPUs to use (applied on restart)

or something similar?

I'll change this to RFE, since at least the current non-intuitive behavior is
documented, for those who bother to read the docs ;-)
Comment 2 raph 2002-10-05 20:15:01 EDT
Other configuration settings besides #CPU's are affected. I didn't search
exhaustively, but did notice CDRom device. Note that the need to restart is not
documented.
Comment 3 Bill Nottingham 2005-02-04 18:09:39 EST
grip is no longer shipped in the development tree; as such, it is unlikely older
bugs will be fixed.

Note You need to log in before you can comment on or make changes to this bug.