Bug 7522 - Annoyances in nethack package, fixes available.
Annoyances in nethack package, fixes available.
Status: CLOSED RAWHIDE
Product: Red Hat Powertools
Classification: Retired
Component: nethack (Show other bugs)
6.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Powers
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-12-02 17:48 EST by Alan Shutko
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-01-12 20:25:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
New spec file (3.01 KB, text/plain)
1999-12-02 22:33 EST, Alan Shutko
no flags Details
My (combined) patch. I can split it if desired. (15.94 KB, patch)
1999-12-02 22:34 EST, Alan Shutko
no flags Details | Diff

  None (edit)
Description Alan Shutko 1999-12-02 17:48:28 EST
I disliked a bunch of stuff with the default powertools nethack compile.
Biggest glitch was the chown in the %post which made verifying it always
complain.  I also disliked the permissions on everything.  Now it is sgid,
as seems to be recommended.  While I was at it, I changed things to compile
as SYSV instead of BSD, since it's really closer.

I have a new patch and a new spec file, and I'll send them in as soon as I
figure out how to attach it to this bug.
Comment 1 Alan Shutko 1999-12-02 22:33:59 EST
Created attachment 20 [details]
New spec file
Comment 2 Alan Shutko 1999-12-02 22:34:59 EST
Created attachment 21 [details]
My (combined) patch.  I can split it if desired.
Comment 3 Tim Powers 1999-12-13 10:27:59 EST
Thanks. I'll  see just how much of this I can incorporate into nethack 3.3.0
which was just released.

Tim
Comment 4 Tim Powers 1999-12-13 10:46:59 EST
Actually, if you have already worked on spec and patch for the 3.3.0 sources it
could help speed things up quite a bit, especially since you use nethack and I
don't :)

Tim
Comment 5 Alan Shutko 1999-12-13 10:51:59 EST
I've reworked and am using a new spec and patch on NH 3.3.0, but I'm seeing a
glitch in the color handling on xterminals.  I see the same problem on their
compiled binary, but I'm not sure I want to spread the RPM until the bug is
corrected (not knowing if it's a compilation bug, or if they broke something).

Let me play with it another day or so, and I'll put the patch and spec here.  By
then, I should be satisfied as to whether it's their problem or my problem.
Comment 6 Alan Shutko 1999-12-13 10:57:59 EST
Whee!  Just discovered it isn't my fault.  I'll go attach the spec and patch
now... feel free to modify the spec, since I'm quite new at modifying them.
FWIW, NH 3.3.0 has a bug in displaying colors when the terminfo entry doesn't
list them... must dig in and look at it.

Attaching, attaching... well, at least I will when I can figure out how on an
existing bug....
Comment 7 Tim Powers 1999-12-13 11:05:59 EST
Just a tip for generating patches, it amkes things easier for us to incorporate
and also is a bit cleaner :)

Go to the pristine source dir, copy the origional files you are going to change
to their filename.suffix. For example if I have to make changes to config.h I
would do this:

	cp config.h config.h.tim

Now edit the origional filename (the one without the new suffix).

Once you are done cd above the top level dir for the package, lets say in this
case nethack-3.3.0, you want to be above that dir, now do this:

gendiff nethack-3.3.0 .tim > nethack.patch

What this does is runs gendiff to look into nethack-3.3.0 where the origional
files are suffixed with .tim, redirect the output to > nethack.patch. Voila, now
there's a patch which we can use without modification :)

Thought that I might let you knwo about this one. I hope it helps some, I do
know that it helps us :)

Tim

Note You need to log in before you can comment on or make changes to this bug.