Bug 752268 - RFE: xml catalog for html, html-single in publican website
RFE: xml catalog for html, html-single in publican website
Status: CLOSED WORKSFORME
Product: Publican
Classification: Community
Component: publican (Show other bugs)
future
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ruediger Landmann
Jeff Fearn
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-08 19:54 EST by Joshua Wulf
Modified: 2014-10-19 18:59 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-03 03:09:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Joshua Wulf 2011-11-08 19:54:38 EST
I'd like to expose the html and html-single versions of documents in a publican website via an xml catalog similar to the current opds one for epub.

We're developing client applications to present the publican website data to mobile device users. Granular navigation information is more bandwidth and device friendly, and offers more possibilities for constructing a device-specific navigation paradigm than the current monolithic toc.


At the moment the hack-around is to use the epub catalog and assume the existence of an html / html-single version of each epub entry.
Comment 1 Jeff Fearn 2011-11-10 02:03:15 EST
If you have a standard in mind we'd look at including it in Publican.

If it's some custom stuff then it should be easy for you to use the DUMP.xml file to make any kind of system you want.

http://jfearn.fedorapeople.org/en-US/Publican/2.7/html/Users_Guide/dump_file.html

The benefit of a standard is we can automate it when a book gets installed or updated as opposed to doing it separately and having it lag behind the site.

Cheers, Jeff.
Comment 2 Joshua Wulf 2012-02-03 03:09:41 EST
The dump file looks like it will do the trick. Thanks!

Note You need to log in before you can comment on or make changes to this bug.