Bug 752319 - "Cannot open an IPMI driver" message from cron
Summary: "Cannot open an IPMI driver" message from cron
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: ipmiutil
Version: 16
Hardware: All
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Andy Cress
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-11-09 07:21 UTC by Jan ONDREJ
Modified: 2012-09-17 21:57 UTC (History)
2 users (show)

Fixed In Version: ipmiutil-2.7.9-3.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-11-16 00:25:20 UTC
Type: ---


Attachments (Terms of Use)

Description Jan ONDREJ 2011-11-09 07:21:10 UTC
Description of problem:
I have ipmiutil installed on my system and each night I get error message from cron. It's right, that there is no /dev/ipmi* device on my system, I have system without IPMI, but I use IPMI as client on my servers. I use IPMI utilities to connect to other hosts, so I don't need an /dev/ipmi*.

Version-Release number of selected component (if applicable):
ipmiutil-2.7.7-1.fc16.x86_64
same on fc15 package

How reproducible:
always

Steps to Reproduce:
1. /etc/cron.daily/checksel
Run this on systems without /dev/ipmi* or similar device.
  
Actual results:
Cannot open an IPMI driver: /dev/imb, /dev/ipmi0, /dev/ipmi/0, 
        /dev/ipmikcs, /dev/ipmi/kcs, libfreeipmi, ldipmi, or direct.

Expected results:
--nothing--

Additional info:
Please, if you consider, that this message should not be turned off, please at least add an configuration option, where I can disable this check. Of may be move this script to an subpackage.

Comment 1 Andy Cress 2011-11-09 15:40:23 UTC
That's certainly a bug.  Two changes are needed:  
1) The checksel script should do nothing and produce no messages if it is run on a system where IPMI is not enabled.
2) The rpm spec file should not install checksel into /etc/cron.daily if IPMI is not enabled.  
I'll work on changing both and submit a patch to the existing 2.7.9-2 version.  Changes will be merged upstream for the next ipmiutil version also.

Comment 2 Fedora Update System 2011-11-10 19:21:58 UTC
ipmiutil-2.7.9-3.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/ipmiutil-2.7.9-3.el6

Comment 3 Fedora Update System 2011-11-11 19:55:02 UTC
Package ipmiutil-2.7.9-3.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing ipmiutil-2.7.9-3.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2011-4952
then log in and leave karma (feedback).

Comment 4 Jan ONDREJ 2011-11-13 06:50:47 UTC
This bug has been reported against Fedora 16. Please, can you release packages for Fedora? I can test them only on Fedora.

Comment 5 Fedora Update System 2011-11-14 15:30:00 UTC
ipmiutil-2.7.9-3.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/ipmiutil-2.7.9-3.fc16

Comment 6 Andy Cress 2011-11-14 15:32:43 UTC
Jan,
Sorry about that.  I had updated rawhide/master/f17 and el6, but not f16.  Update to f16 is complete now, link above.
Andy

Comment 7 Fedora Update System 2011-11-16 00:25:20 UTC
ipmiutil-2.7.9-3.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2011-11-28 19:29:29 UTC
ipmiutil-2.7.9-3.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Michael Shigorin 2012-04-21 15:51:47 UTC
(In reply to comment #1)
> That's certainly a bug.  Two changes are needed:  
> 1) The checksel script should do nothing and produce no messages if it is run
> on a system where IPMI is not enabled.
Indeed.

> 2) The rpm spec file should not install checksel into /etc/cron.daily if IPMI
> is not enabled.  
Or just package it separately as I do in ALT Linux.  Upstream has removed installing the script by default with 2.8.2 -- which is a minor hassle/regression IMHO.

Comment 10 Andy Cress 2012-04-23 13:44:51 UTC
Packaging it separately is not warranted in this case since this is the only difference between client & server installs, and separate packages would produce more hassle/regression, IMO.  The rpm postinstall will install the checksel script if it detects that the system supports IPMI.  The priority for this package is to make the user experience easier & simpler.  
The changes to fix this bug are included in ipmiutil-2.7.9-3 and later.  The 2.8.2 version has also been updated into f16, f17 and epel6.

Comment 11 Michael Shigorin 2012-04-23 18:14:56 UTC
(In reply to comment #10)
> and separate packages would produce more hassle/regression, IMO
For a distro that used to ship perl wholesale, probably yes.  For the rest of us, well no. :)

> The rpm postinstall will install the checksel script if it detects
> that the system supports IPMI.
Hope you do understand the existence of corner cases like "BMC wasn't configured", "kernel modules weren't loaded" etc to tell that...

OK, my point was to mention that Fedora/RHEL "bug" (which is rather a distro's take in fact) spoiled a tiny bit of upstream functionality; A Bad Thing (TM).

Comment 12 Fedora Update System 2012-08-21 16:16:19 UTC
ipmiutil-2.8.5-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/ipmiutil-2.8.5-2.fc18

Comment 13 Fedora Update System 2012-09-17 21:57:39 UTC
ipmiutil-2.8.5-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.