Bug 752393 - Unimplemented block at relaxng.c:8948
Summary: Unimplemented block at relaxng.c:8948
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libxml2
Version: 6.2
Hardware: Unspecified
OS: Linux
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Daniel Veillard
QA Contact: qe-baseos-tools-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-11-09 11:49 UTC by Dag Wieers
Modified: 2012-10-16 05:43 UTC (History)
8 users (show)

Fixed In Version: libxml2-2.7.6-8.el6_3.3
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-10-16 05:43:58 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Dag Wieers 2011-11-09 11:49:04 UTC
Description of problem:
When validating ODF documents using xmllint and the RelaxNG schemas of the ODF standard, xmllint bails out with the message:

    Unimplemented block at relaxng.c:8948

Apparently this is a known issue that is fixed in later libxml2 releases. This issue prevents ODF validation on RHEL6.


How reproducible:
Everytime


Steps to Reproduce:
1. Write out an ODF document (might need some complexity)
2. Run: xmllint --noout --relaxng OpenDocument-v1.2-cs01-schema.rng document.odt

Actual results:
Validation fails with message: Unimplemented block at relaxng.c:8948

Expected results:
Validation works.

Additional info:

Comment 1 Dag Wieers 2011-11-09 11:50:02 UTC
There is a discussion on the very same issue at:

    http://mail.gnome.org/archives/xml/2010-January/msg00031.html

Comment 3 Daniel Veillard 2011-11-09 13:53:06 UTC
Actually that doesn't look like fixed upstream, I'm afraid I failed to
go through and fix the problem :-\

paphio:~/XML -> xmllint --noout --relaxng schema.rng test.xml 
Unimplemented block at relaxng.c:8949
test.xml:2: element a: Relax-NG validity error : Element a failed to validate attributes
test.xml fails to validate
paphio:~/XML -> 

Daniel

Comment 4 Dag Wieers 2011-11-09 16:23:03 UTC
Thanks for the information, it saves me the time to package anything newer for RHEL and see if it works, which I planned to do this evening ;-)

Comment 5 Daniel Veillard 2011-11-10 12:11:31 UTC
Okay I finally took the time to fix it:
http://git.gnome.org/browse/libxml2/commit/?id=7dd0d916c6a92ca4a398b8bc56fb0d7f98df00b6

I wouldn't mind fixing it for 6.2 if people agree it's worth it.
ODF is relatively important, it's a shame I didn't fixed that earlier
but I forgot about the issue !

Daniel

Comment 6 Daniel Veillard 2011-11-10 12:12:21 UTC
Err 6.3, that would be too late for 6.2 now I assume.

Comment 7 Dag Wieers 2011-11-14 22:49:25 UTC
I think it is worth it, but I am hardly the most objective person :-)

Thanks for your help !

Comment 14 RHEL Program Management 2012-09-07 04:58:22 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.

Comment 18 Daniel Veillard 2012-10-16 05:43:58 UTC
Oh actually that was fixed when we pushed a security update in September,
it should be available in RHEL-6.3 updates as libxml2-2.7.6-8.el6_3.3

Daniel


Note You need to log in before you can comment on or make changes to this bug.