Bug 75240 - kernel makefile is broken
kernel makefile is broken
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
8.0
athlon Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-05 16:48 EDT by David A. De Graaf
Modified: 2007-04-18 12:47 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-06 04:41:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Explanation of kernel makefile breakdowns (4.19 KB, text/plain)
2002-10-05 16:50 EDT, David A. De Graaf
no flags Details

  None (edit)
Description David A. De Graaf 2002-10-05 16:48:25 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.0 (X11; Linux i586; U;) Gecko/20020408

Description of problem:
Rbuilding the kernel resulted in four major failures
that need urgently to be fixed.
In addition, the pcmcia-cs package from David Hinds
no longer works.
I hope bugzilla gives me a chance to append the full explanation.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Build a slightly modified kernel; deal with the bugs.
2.
3.
	

Actual Results:  Kernel build failed in four ways.

Additional info:
Comment 1 David A. De Graaf 2002-10-05 16:50:04 EDT
Created attachment 78985 [details]
Explanation of kernel makefile breakdowns
Comment 2 Arjan van de Ven 2002-10-06 04:41:42 EDT
well you did a make install before make modules_install... that's not good
since make install needs the modules installed ;(
Comment 3 David A. De Graaf 2002-10-06 14:34:13 EDT
I swear, I've used the sequence
   make dep clean bzImage install modules modules_install
successfully in the past.  I copied it from somewhere; I'm not capable
of making this up.   :-)
However, your logic is impeccable.  So I repeated the experiment with
   make dep clean bzImage modules modules_install install
and everything worked perfectly.

Item-by-item:
1)  The new modules directory was automatically created -
       /lib/modules/2.4.18-14nPb
2)  There were no complaints about devlist.h or classlist.h.
3)  The initrd-2.4.18-14nPb.img was correctly made and it boots.
4)  There are still 5691 warning messages, but as I said, 
they're only warnings.

Sadly, my pcmcia adapter still doesn't work, so I have no wireless
communication.  I still get
  bind 'orinoco_cs' to socket 0 failed: Operation not permitted
but that someone else's problem, I guess.

I withdraw this bugzilla report.
Thanks, arjanv

Note You need to log in before you can comment on or make changes to this bug.