Bug 752531 - N-E-V-R for preupgrade for f16 < N-E-V-R for preupgrade for f15
N-E-V-R for preupgrade for f16 < N-E-V-R for preupgrade for f15
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: preupgrade (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-09 14:09 EST by Alex Lancaster
Modified: 2011-11-29 20:51 EST (History)
2 users (show)

See Also:
Fixed In Version: preupgrade-1.1.10-1.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-11-29 20:51:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alex Lancaster 2011-11-09 14:09:09 EST
preupgrade-1.1.10-1.fc15

was pushed to f15 stable in this update:

 https://admin.fedoraproject.org/updates/FEDORA-2011-14766

without a corresponding f16 update, which is still stuck at:

preupgrade-1.1.9-1.fc16

However, I notice that preupgrade-1.1.10-1.fc16 *has* been built, but no corresponding update in bodhi, causing preupgrade to look like an orphan:

This is somewhat ironic because a user following preupgrade's *own* instructions: https://fedoraproject.org/wiki/How_to_use_PreUpgrade#Removing_unsupported_packages would cause somebody to remove upgrade:

# sudo package-cleanup --orphans
preupgrade-1.1.10-1.fc15.noarch
Comment 1 Nicola Soranzo 2011-11-17 10:25:45 EST
In fact, this F15 breaks the upgrade path, described at:

http://fedoraproject.org/wiki/Packaging/NamingGuidelines#Package_Versioning
Comment 2 Fedora Update System 2011-11-17 12:05:40 EST
preupgrade-1.1.10-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/preupgrade-1.1.10-1.fc16
Comment 3 Alex Lancaster 2011-11-17 12:06:25 EST
Looks like it was built in koji back on Fri, 21 Oct 2011:

http://koji.fedoraproject.org/koji/buildinfo?buildID=269924

but no corresponding update in bodhi yet:

https://admin.fedoraproject.org/updates/preupgrade

I've taken the liberty of pushing the update to updates-testing myself.
Comment 4 Fedora Update System 2011-11-19 00:58:56 EST
Package preupgrade-1.1.10-1.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing preupgrade-1.1.10-1.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-16090/preupgrade-1.1.10-1.fc16
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2011-11-29 20:51:53 EST
preupgrade-1.1.10-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.