Bug 752536 - Unable to open Servers within the Windows console
Summary: Unable to open Servers within the Windows console
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: 389
Classification: Retired
Component: Directory Console
Version: 7.1
Hardware: i686
OS: Windows
unspecified
high
Target Milestone: ---
Assignee: Rich Megginson
QA Contact: Chandrasekar Kannan
URL:
Whiteboard:
Depends On:
Blocks: 389_1.2.10
TreeView+ depends on / blocked
 
Reported: 2011-11-09 19:25 UTC by John Shaw-Miller
Modified: 2015-01-04 23:51 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-03-23 14:39:59 UTC


Attachments (Terms of Use)

Description John Shaw-Miller 2011-11-09 19:25:20 UTC
Description of problem:

I upgraded both my Directory Servers to 8.2.6 and since then I am unable to connect to the servers using the windows tools

Version-Release number of selected component (if applicable):

Console Framework 1.1.5

How reproducible:

Each time

Steps to Reproduce:
1. Open 389 Console
2. Right click to expand the server
3. Right click to expand the Server Group
  
Actual results:

Results in a circle continually on the screen

Expected results:

I can open the actual server and administer it

Additional info:


C:\Program Files\389 Management Console>"java" "-Djava.library.path=." -cp "./js
s4.jar;./ldapjdk.jar;./idm-console-base.jar;./idm-console-mcc.jar;./idm-console-
mcc_en.jar;./idm-console-nmclf.jar;./idm-console-nmclf_en.jar;./389-console_en.j
ar" -Djava.util.prefs.systemRoot=/.389-console -Djava.util.prefs.userRoot=/.389-
console com.netscape.management.client.console.Console
Uncaught error fetching image:
java.lang.NullPointerException
        at java.io.FileInputStream.<init>(Unknown Source)
        at java.io.FileInputStream.<init>(Unknown Source)
        at sun.awt.image.FileImageSource.getDecoder(Unknown Source)
        at sun.awt.image.InputStreamImageSource.doFetch(Unknown Source)
        at sun.awt.image.ImageFetcher.fetchloop(Unknown Source)
        at sun.awt.image.ImageFetcher.run(Unknown Source)

Comment 1 Martin Kosek 2012-01-04 13:13:20 UTC
Upstream ticket:
https://fedorahosted.org/389/ticket/14

Comment 2 Rich Megginson 2012-01-10 17:59:37 UTC
marking as screened because it has been cloned upstream

Comment 3 Rich Megginson 2012-01-26 16:02:49 UTC
Can't reproduce - steps:

Up to date windows 2008 64-bit system
Up to date Oracle/Sun Java

Installed the latest Windows Console for 64-bit from port389.org

Installed a RHEL5 system with RHDS 8.2.8

Installed a F-16 system with the latest 389

Was able to use the console to successfully manage both

One thing I noticed was that using the 389-console to manage RHDS did not display the red/black Red Hat Directory Server banner when opening the directory part of the console.  I did not see an exception.  Everything works fine regardless.


Note You need to log in before you can comment on or make changes to this bug.