Bug 752611 - Gnome Online Account with Google "Error getting request token. Bad Request"
Gnome Online Account with Google "Error getting request token. Bad Request"
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gnome-online-accounts (Show other bugs)
16
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-09 18:55 EST by Vincent passaro
Modified: 2012-12-21 22:43 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-26 05:25:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Error Pop Up (10.61 KB, image/png)
2011-11-09 18:55 EST, Vincent passaro
no flags Details

  None (edit)
Description Vincent passaro 2011-11-09 18:55:39 EST
Created attachment 532699 [details]
Error Pop Up

Description of problem:

Gnome-Online-Accounts errors when trying to select Google.


Version-Release number of selected component (if applicable):

[root@W520 Downloads]# rpm -qa|grep -i gnome-online
gnome-online-accounts-3.2.1-2.fc16.x86_64

How reproducible:

Always


Steps to Reproduce:
1. Select online accounts
2. Select Google (only available option from dropdown menu)
3. Error received is "Error getting request token.  Bad Request"
  
Actual results:

Should be able to log into Google account.


Expected results:

Receive error 


Additional info:

Attached screen shot of error pop up window.
Comment 1 Petr Holasek 2011-11-13 04:29:16 EST
Hi,

similar problem on the same versions with same Steps to Reproduce,
but result is error pop up "Error getting a Request Token: Cannot resolve proxy hostname ()". Of course, I am connected to the net.

Regards,
Petr
Comment 2 Pierre-Antoine Roiron 2011-11-13 05:05:51 EST
I had the same bug using a f16 live session (live cd), using both wifi or ethernet connection. After a fresh install on my hard drive, that bug disappeared using an ethernet connection (not tested yet with a wifi connection).
Comment 3 Vincent passaro 2011-11-13 22:48:36 EST
My fix was similar.  I had to re-install for the account setup to function properly.
Comment 4 Matthias Clasen 2011-11-14 16:24:06 EST
Works fine here.
Comment 5 Pierre-Antoine Roiron 2011-11-15 04:18:33 EST
(In reply to comment #2)
> I had the same bug using a f16 live session (live cd), using both wifi or
> ethernet connection. After a fresh install on my hard drive, that bug
> disappeared using an ethernet connection (not tested yet with a wifi
> connection).

Tested with a wifi connection : OK.
Comment 6 Vincent passaro 2011-11-23 03:17:38 EST
I guess close this out?
Comment 7 Volker Braun 2011-11-23 15:35:07 EST
I also got the "Error getting a Request Token: Cannot resolve proxy hostname ()" error. Under All Settings->Network->NetworkProxy I had entered a manual FTP proxy but nothing else. 

After switching to "None" (no proxy), the gnome online accounts setup works.
Comment 8 Germán Ríos 2011-11-27 14:21:01 EST
After a fresh install of F16 and update before add a online account, I have the same issue, "Error creating account" Error getting a Request Token: Bad Request"
Comment 9 Juergen Schraten 2011-11-29 03:23:54 EST
Same problem with an interesting observation:

Both machines are i686, both connected via wifi.

On machine 1 I created google-online-accounts before I updated. It created those accounts properly, but doesn't synchronize them now. I'm not able to change or delete items.

On machine 2 I updated before trying to set up google-online-accounts. Now I get "Error getting request token.  Bad Request"

On third machine, x86_64 tough, everything works fine, was able to create accounts after update and synchronizes properly.

Any additional information wanted? Please ask!
Comment 10 Juergen Schraten 2011-11-29 06:45:18 EST
Good news: Update to ibus-1.4.0-11 did help on one machine (the other one I'll update tonight).
Comment 11 sawrub 2012-02-12 09:53:15 EST
(In reply to comment #7)
> I also got the "Error getting a Request Token: Cannot resolve proxy hostname
> ()" error. Under All Settings->Network->NetworkProxy I had entered a manual FTP
> proxy but nothing else. 
> 
> After switching to "None" (no proxy), the gnome online accounts setup works.

works for me.....
Comment 12 Samuel Cavazos 2012-03-14 12:07:03 EDT
Been having this problem for a few weeks now. Not only was online accounts down, so was a gnome weather extension I have installed. As Volker Braun stated above, switching the proxy to "none" solved the problem here.
Comment 13 Debarshi Ray 2012-03-26 05:25:14 EDT
If your system time is not set correctly then you might get:
"Error getting a Request Token: Bad Request"

Google is quite picky about the time being correct.

Closing it for the time being as NOTABUG, but feel free to reopen if the problem persists.
Comment 14 Jagar 2012-12-21 22:43:16 EST
(In reply to comment #13)
> If your system time is not set correctly then you might get:
> "Error getting a Request Token: Bad Request"
> 
> Google is quite picky about the time being correct.
> 
> Closing it for the time being as NOTABUG, but feel free to reopen if the
> problem persists.

Debarshi Ray, thank you and this worked great. When you mentioned the time, I looked at the time on my computer and it was wrong. I enabled network time and tried it again and worked like a charm.

Thanks again

Note You need to log in before you can comment on or make changes to this bug.