Bug 75269 - cpio won't span volumes
Summary: cpio won't span volumes
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: cpio   
(Show other bugs)
Version: 8.0
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Peter Vrabec
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-06 16:54 UTC by David A. De Graaf
Modified: 2007-04-18 16:47 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-19 11:02:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Demo of cpio bug (2.09 KB, text/plain)
2002-10-06 16:55 UTC, David A. De Graaf
no flags Details

Description David A. De Graaf 2002-10-06 16:54:18 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.0 (X11; Linux i586; U;) Gecko/20020408

Description of problem:
When a cpio archive spans multiple media (floppies) there's a
prompt for next one on output, but not on input.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. cpio -o  a large file
2. cpio -i  the disks
3.
	

Actual Results:  cpio -o  prompts for additional disks
cpio -i  claims an I/O error at end of first disk, instead
         of asking for next disk

See example in attachment.

Additional info:

Comment 1 David A. De Graaf 2002-10-06 16:55:18 UTC
Created attachment 79064 [details]
Demo of cpio bug

Comment 2 David A. De Graaf 2005-01-18 17:34:50 UTC
Thanks for fixing the cpio program;  it works correctly in Fedora Core
3, and maybe sooner - I didn't check those.

However, you failed to fix the man page, too.  There's no mention of
the fact that cpio is intended to span multiple media.  I had
suggested possible wording (taken from the SysV manual) in the attachment.

Please add something.

Comment 3 Peter Vrabec 2005-01-19 11:02:01 UTC
Why?

I do not think it's necessary to add anything to man page.
It's mentioned in  "-M MESSAGE, --message=MESSAGE" option.




Comment 4 David A. De Graaf 2005-01-19 17:33:20 UTC
OK, I agree.  That little note does not exactly leap out at you,
but it is there for the determined reader.  Good enough, I guess.


Note You need to log in before you can comment on or make changes to this bug.