Bug 7527 - Install problems (and workarounds) installing Redhat 6.1
Install problems (and workarounds) installing Redhat 6.1
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-12-02 20:41 EST by Red Hat Bugzilla
Modified: 2015-01-07 18:39 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-01 12:28:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Red Hat Bugzilla 1999-12-02 20:41:20 EST
Instal problems (and workarounds) installing Redhat  6.1

Since I was eventually able to get Redhat 6.1 installed, I am writing this
problem report to hopefully help others to avoid the many hours of pain I
had installing 6.1 on a system has no problem installing and running
Redhat 6.0.

Problems:

1 On a system with two SCSI hard drives, if there are no partitions on the
second hard drive both graphic and text mode install crash immediately
after setting mount points.  In graphic mode the system reboots with no
error visible error message.  In text mode error message is
	Install exited abnormally
		Received signal 11
And then the system reboots.

This problem occurs with or without the 22 October install updates, with
or without the 18 October driver disk, and in both normal and expert
modes.  Redhat 6.0 installs normally with the same unpartitioned second
drive.  I don't know if this is also a problem if either or both of the
drives are IDE.

The workaround I used was to create and format a native Linux partition
that used the entire second drive).  My guess is that any valid partition
on the second drive would fix the problem.

2  On a system with two different SCSI adapters with the hard drives on
one adapter and a ZIP drive on the other adapter, the bootdisk created by
6.1 install may load the SCSI drivers in reverse order than the install
boot disk cause the zip drive to become SDA and the first hard drive to be
SDB.  This always happens on my system and does not happen when installing
6.0 (since there is a 50% chance of the modules loading in the correct
order, this may not happen on all systems).  Error messages

Vfs: Cannot open root device 08:0B
Kernel Panic :VFS: unable to mount root FS on 08:0B

It appears to me that this is the same problem as #6772 in Bugzilla.  The
workaround I used was to physically remove the second SCSI adapter (with
Zip drive) which caused the bootdisk to be created with only one the SCSI
module (aic7xxx) for the hard drive.  I think that an easier workaround
would be at the point install is waiting for you to insert the floppy, you
could use [ctrl] [Alt] [F2] to get a shell prompt and use vi to fix
/etc/conf.modules.  I don't plan on trying this alternate unless I have to
reinstall 6.1 on this system.


Background:

Tried graphic install of Redhat 6.1 (boxed set) on first hard drive (18 GB
sda) of on system with two SCSI adapters, two hard drives on "1st " SCSI
adapter, SCSI Zip 100 and "2nd" adapter, and no partitions defined on
second hard drive - more complete hardware configuration below
 /boot	on sda5 22 megabyte completely below cylinder 1024
/	on sda11 1.6 GB
swap	on sda12 56 MB

Install failed and rebooted after setting mount points in Druid on SDA
(first hard drive)

Downloaded 22 October install updates and 18 October driver disks and
created floppies

Tried graphic install  - install failed same place (after setting mount in
Druid) with or without the driver (which I don't think I need) and updates
in normal an expert mode

Tried text mode install - fails after setting mount - error messages
	Install exited abnormally
		Received signal 11


Search Bugzilla database for 6.1 install problems  - saw a couple that
looked the same, but the only suggestions was that it was a hardware
problem.  Also checked linux.redhat.install newsgroup.

Since I had never tried installing Linux on this system, I thought I might
have a hardware problem.  Installed Redhat 6.0 - only problem was the 6.0
SVGA driver for X doesn't support my G400 card so Gnome was running in
320x240 resolution (I bought 6.1 primarily because the Xfree86 in 6.0 does
support this card).

Upgraded from 6.0 to 6.1 upgrade appeared to complete normally - tried to
boot from bootdisk - got

Vfs: Cannot open root device 08:0B
Kernel Panic :VFS: unable to mount root FS on 08:0B


Tried 6.0 bootdisk - get error messages about wrong kernel, but system
came up and Gnome was running in 640x480.  However, my network card didn't
work - probably due to kernel / module version errors

To see if install CDROM was bad, I installed 6.1 on another system with a
single IDE hard drive that had both CDROM and ZIP on a single SCSI
adapter.  Druid refused to create root partition beyond 1024 cylinder
limit (not enough space error) - used 6.0 rescue disk and fdisk to create
the partition and graphic install completed without any errors.  However,
Gnome help browser crashes immediately - everything else appears to work

At this point I booted the first system from both the 6.0 bootdisk that
comes up and the 6.1 bootdisk that dies.  Found that the 6.1 disk loads
the ncr538xx module before the ada7xxx and assigns sda to the ZIP drive
and sdb to the first hard drive.

Opened up the computer case and removed the ncr538xx (Promise) SCSI card
and started graphic install - failed after setting mount points in Druid
as before.  Tried text install - same signal 11
Crash

Since it had been a couple of days I went back to Redhat web site and
checked erreta and Bugzilla - no help

At this point the only difference that I could see between this system and
the my other system that worked was that this system has two SCSI hard
drives while the system that worked has a single 18 GB IDE drive.  I
thought about removing the second drive, but it was the device that was
terminating the SCSI bus which requires changing the strapping on another
drive.  Then I remembered the warning about the need to have media
installed in all the removable media drives during install.  This
suggested that a second drive without any partitions might be a problem
(although it was not a problem for 6.0 install)

I used partition magic to create and format a single native Linux extended
partiotion on the entire second drive.

Next I started the 6.1 graphic mode install.  It completed normally and I
was able to boot with the bootdisk it created (which had only the onboard
SCSI adapter).

I shut the system down and reinstalled the second SCSI adapter.  The
bootdisk still worked because it only loaded the aic7xxx module.

I used linuxconf to add the ncr538xx module and mkbootdisk to make a new
bootdisk.
At this point /etc/conf.modules contained

alias scsi_hostadapter aic7xxx
alias eth0 tulip
alias scsi_hostadapter1 ncr53c8xx


Entered shutdown -r now

New bootdisk still loaded the ncr538xx first (even though it was second in
conf.modules) and failed because hard drive became sdb.

After thinking about the problem I remembered reading in some FAQ or HOWTO
that the first SCSI is zero and that the ncr53.. had a 1 after
scsi_hostadapter so I changed /etc/conf.modules to
alias scsi_hostadapter0 aic7xxx
alias eth0 tulip
alias scsi_hostadapter1 ncr53c8xx

I then used mkbootdisk to make a new bootdisk.


Entered shutdown -r now

aic7xxx loaded first and everything that I have tried has worked including
my Intel printserver


Detailed Hardware configuration:

ASUS P2B-S motherboard with onboard AIC-7890 and AIC-3860 SCSI (like an
Adaptec 2940 U2W] - uses aic7xxx driver module)
Pentium II 350 MHz
256 megabyte PC100 ram
Promise easy SCSI card - uses ncr538xx driver module
Linksys LNE100TX - uses tulip driver module
Matrox G400 Max 32 megabyte video memory (needs SVGA driver included in
6.1)
2 hard drives and CDROM drive connected to onboard SCSI (aic7xxx driver)
CDRW and ZIP drive connected to Promise SCSI adapter
Comment 1 Red Hat Bugzilla 2000-02-02 12:12:59 EST
I have a setup close to yours, a single SCSI controller (Mylex BT-950) with two
hard disks, and the same problem with the installer: After setting the mount
points the graphical installer dies with a X11 "security" (?) related message.
The text based installer dies with the same "signal 11" error. But your guess
for the problem and the workaround isn't probably correct.
I already have a 5.2 system running and both disks are partitioned,
which partitions I wish to use with 6.1. Despite of this the installer dies.
Same error appears whether I use the installer update floppies or not, and
the same error appeared in a fresh install before I had 5.2 installed.
Comment 2 Red Hat Bugzilla 2000-02-09 09:41:59 EST
Issues have been added to test plan for future releases.  Thanks!
Comment 3 Red Hat Bugzilla 2000-05-10 12:09:59 EDT
Cannot reproduce original problem "1" using Adaptec AHA-2940U2/W on local
hardware (older Asus TX board... ) ...
Comment 4 Red Hat Bugzilla 2000-05-10 12:27:59 EDT
for the original problem "2" above (loading modules out-of-order making install
drive sda-> sdb), you could try making an initrd with the aic7xxx module
explicitly loaded ahead of the ncr53c8xx module (below is a sample to use with
6.2):

[root@foobar /root]# mkinitrd --preload aic7xxx --with=ncr53c8xx
/boot/initrd-2.2.14-5.0.img 2.2.14-5.0

Note You need to log in before you can comment on or make changes to this bug.