This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 752702 - "you have not created a bootloader stage1 device" error
"you have not created a bootloader stage1 device" error
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-10 02:26 EST by Martin Dengler
Modified: 2013-09-07 09:21 EDT (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 739389
Environment:
Last Closed: 2011-11-14 12:03:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
/tmp/anaconda.log as requested (4.22 KB, text/plain)
2011-11-10 02:28 EST, Martin Dengler
no flags Details
/tmp/storage.log as requested (267.54 KB, text/plain)
2011-11-10 02:29 EST, Martin Dengler
no flags Details
/tmp/program.log as requested (72.55 KB, text/plain)
2011-11-10 02:30 EST, Martin Dengler
no flags Details
screenshot of error message despite creating bios boot partition (92.69 KB, image/png)
2011-11-11 05:04 EST, Martin Dengler
no flags Details
storage log after creating bios boot partition (405.69 KB, text/x-log)
2011-11-11 05:05 EST, Martin Dengler
no flags Details
anaconda.log after creating bios boot partition (4.96 KB, text/plain)
2011-11-11 05:06 EST, Martin Dengler
no flags Details
program.log after creating bios boot partition (97.08 KB, text/plain)
2011-11-11 05:06 EST, Martin Dengler
no flags Details
straw man patch (1.51 KB, text/plain)
2011-11-15 02:23 EST, Martin Dengler
no flags Details

  None (edit)
Description Martin Dengler 2011-11-10 02:26:42 EST
+++ This bug was initially created as a clone of Bug #739389 +++

I am trying to install from the Fedora 16 x86_64 Live ISO image.

I selected manual partitioning and had already partitioned my disk, so I just set the mountpoints and filesystem-to-format-as:

# parted /dev/sda print
Model: ATA M4-CT256M4SSD2 (scsi)
Disk /dev/sda: 256GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number  Start   End     Size    Type     File system  Flags
 1      4194kB  1000MB  996MB   primary  fat32        boot, lba
 2      1000MB  5000MB  3999MB  primary
 3      5000MB  100GB   95.0GB  primary
 4      100GB   255GB   155GB   primary

(Background: partition #1 is where I have livecd-iso-to-disk'd the Live ISO, and anaconda is showing its "Type" as "EFI System Partition")

I get the following partitioning error: "you have not created a bootloader stage1 device".

I noticed in /tmp/storage.log that my disklabel is detected as msdos:

# grep "  format = existing" /tmp/storage.log | sort | uniq
  format = existing efi filesystem
  format = existing ext4 filesystem
  format = existing msdos disklabel
  format = existing None


...and given that, I'm not sure why I'm being asked about a BIOS boot partition.

Is this a bug or am I misunderstanding something?

I will attach

  /tmp/anaconda.log
  /tmp/storage.log
  /tmp/program.log
  /tmp/syslog if non-empty, else /var/log/messages

Thanks.

PS - This is the same error message as bug #739389, but because I actually do not have a GPT disk I opened a new bug.
Comment 1 Martin Dengler 2011-11-10 02:28:28 EST
Created attachment 532736 [details]
/tmp/anaconda.log as requested
Comment 2 Martin Dengler 2011-11-10 02:29:25 EST
Created attachment 532737 [details]
/tmp/storage.log as requested
Comment 3 Martin Dengler 2011-11-10 02:30:22 EST
Created attachment 532739 [details]
/tmp/program.log as requested
Comment 4 David Lehman 2011-11-10 08:54:38 EST
Because of the widespread use of USB install media we do not allow bootloader installation to the device that contains the install media (see bug 750469 ). As a result of that, you will have to use removable media.
Comment 5 Adam Williamson 2011-11-10 21:14:32 EST
dlehman: so, NOTABUG?



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 6 Martin Dengler 2011-11-11 04:40:25 EST
(In reply to comment #5)
> dlehman: so, NOTABUG?

Well, I'm not sure why we wouldn't want to do what I'm doing (running the installer from a partition on the same device as the partition to which one is installing Fedora), so it would be nice to be able to do that.  I'm going to manually back out anaconda commit http://git.fedorahosted.org/git/?p=anaconda.git;a=blobdiff;f=pyanaconda/bootloader.py;h=547f7b81a4a35205b522ce9542ad5e5fc5e5b59d;hp=6250f74e91a64d542c4fc9d02dacf15b6dd450bf;hb=74c634f1f90fbe1ee4c283deabd65fb66e5bbebe;hpb=fc87b77ab69befe900d502bc2a17a5d675548eb1 from my Live image's anaconda to try to finish the install, but there is probably a better way.  

A straw man: a scary-looking option to "allow bootloader installation to same device as holds installation media" would make it possible.

I'm open to suggestions as to what patch might be acceptable and I can try to help.
Comment 7 Martin Dengler 2011-11-11 05:00:39 EST
(In reply to comment #6)
> I'm going to
> manually back out anaconda commit
> http://git.fedorahosted.org/git/?p=anaconda.git;a=blobdiff;f=pyanaconda/bootloader.py;h=547f7b81a4a35205b522ce9542ad5e5fc5e5b59d;hp=6250f74e91a64d542c4fc9d02dacf15b6dd450bf;hb=74c634f1f90fbe1ee4c283deabd65fb66e5bbebe;hpb=fc87b77ab69befe900d502bc2a17a5d675548eb1
> from my Live image's anaconda to try to finish the install

That didn't work, and even creating a bios boot partition still results in the message "you have not created a bootloader stage1 device".

I will attach logs and a screenshot.
Comment 8 Martin Dengler 2011-11-11 05:04:21 EST
Created attachment 533008 [details]
screenshot of error message despite creating bios boot partition
Comment 9 Martin Dengler 2011-11-11 05:05:32 EST
Created attachment 533009 [details]
storage log after creating bios boot partition
Comment 10 Martin Dengler 2011-11-11 05:06:17 EST
Created attachment 533010 [details]
anaconda.log after creating bios boot partition
Comment 11 Martin Dengler 2011-11-11 05:06:54 EST
Created attachment 533011 [details]
program.log after creating bios boot partition
Comment 12 birger 2011-11-11 05:08:14 EST
This breaks a very nice to maintain linux desktops.

When a system has been fubar'ed it is nice to have a small partition on the disk set up to boot anaconda with the necessary options to start a kickstart-install that wipes the system partitions and reinstalls a clean system.

If the system is still up and on the net it is very easy to remotely log in and set up grub to initiate a reinstall on reboot. Otherwise, it is usually possible to guide a user to fire the reinstall manually from the grub menu.

We used this at the university where I used to work.

At the very least this needs to be something we can override in the kickstart file. We need to be able to install bootloader on the disk the installer is booted from.
Comment 13 David Lehman 2011-11-11 09:11:56 EST
Martin, you'll also want to revert these commits to install the bootloader to sda:

commit 38c6764de599859fe36c0ea58ad03aaf81992d86
commit 74c634f1f90fbe1ee4c283deabd65fb66e5bbebe
Comment 14 Martin Dengler 2011-11-15 00:57:58 EST
David,

This is a regression (right?) and undesired behavior.  Please can you re-open and give some guidance as to what type of patch you might accept.  Installing from a small partition on the installation-target media is quite a valid use case.

I will attach a straw-man patch.

Martin
Comment 15 Martin Dengler 2011-11-15 02:23:53 EST
Created attachment 533693 [details]
straw man patch
Comment 16 nbeier 2013-09-07 09:21:14 EDT
This is problematic in several ways.

1) The message is unhelpful.
* It is not clear if it is a partition or a complete device, that is not created
* It is not clear why this is a problem
* It is not clear what can satisfy the Anaconda checks.

2)
On Fedora 19 (LXDE spin) this message is shown regardless if a boot loader is chosen to be installed or not. On the screen "Installation destination", there is a clickable text link to a dialog, where a disk can be set as "boot device". The choice here does not affect Anaconda, as it throws the error "you have not created a bootloader stage1 target device" either way.

3)
If this error message is triggered by running the live image off one partition and setting the install target to other partitions not in use, but on the same disk, then the error message is unusable to regular users.

Note You need to log in before you can comment on or make changes to this bug.