This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 752802 - Enhancement - API documentation not updated by the erratum
Enhancement - API documentation not updated by the erratum
Status: CLOSED ERRATA
Product: Red Hat Satellite 5
Classification: Red Hat
Component: API (Show other bugs)
540
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tomas Lestach
Dimitar Yordanov
: FutureFeature
Depends On:
Blocks: sat54-errata
  Show dependency treegraph
 
Reported: 2011-11-10 08:12 EST by Tomas Lestach
Modified: 2011-11-15 09:08 EST (History)
1 user (show)

See Also:
Fixed In Version: spacewalk-java-1.2.39-108
Doc Type: Enhancement
Doc Text:
Previously, the API documentation was not distributed as pre-compiled JavaServer Pages (JSP); Tomcat compiled these pages on demand and stored them in the cache. Consequent to this, users were unable to see any updates to the API documentation, because Tomcat kept serving the old content from the cache. The documentation is now served in a pre-compiled form.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-11-15 09:08:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tomas Lestach 2011-11-10 08:12:51 EST
Description of problem:
spacewalk-java erratum introduced new APi calls, but API documentation didin't change on rhn/apidoc/index.jsp

Version-Release number of selected component (if applicable):
sat54

How reproducible:
always

Steps to Reproduce:
1. browse current api documentation
2. apply a spacewalk-java erratum containing updated or newly introduced API calls
3. check API documentation for changes
  
Actual results:
no changes seen

Expected results:
API documentation corresponds to the actual API capabilities

Additional info:
Shipped apidoc jsp files are not precompiled. Tomcat compiles them on demand and stores them in /var/cache/tomcat[56]/work/ and uses them even if the original jsp changed.
Comment 1 Tomas Lestach 2011-11-10 08:14:19 EST
A workaround obviously is to delete tomcat cache:

rm -rf /var/cache/tomcat[56]/work/Catalina/localhost/rhn
Comment 2 Tomas Lestach 2011-11-10 08:15:26 EST
Precompile also apidoc jsp pages in build time ...

spacewalk.git: c4f9c6555bcb9efd7bb9ea521d9e83663974c8b3
Comment 5 Tomas Lestach 2011-11-10 08:34:56 EST
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause:
API documentation jsp pages weren't shipped pre-compiled.
Tomcat compiled those jsp pages on demand and stored them into the cache. Those compiled pages were served also when the original jsp pages go updated by an erratum rpm.
Consequence:
The user didn't see a change in the API documentation after applying of erratum with API changes.
Fix:
Shipping pre-compiled API documentation.
Result:
The user sees API documentation that corresponds to the actual API capabilities.
Comment 8 Jaromir Hradilek 2011-11-11 09:02:36 EST
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1,9 +1 @@
-Cause:
+Previously, the API documentation was not distributed as pre-compiled JavaServer Pages (JSP); Tomcat compiled these pages on demand and stored them in the cache. Consequent to this, users were unable to see any updates to the API documentation, because Tomcat kept serving the old content from the cache. The documentation is now served in a pre-compiled form.-API documentation jsp pages weren't shipped pre-compiled.
-Tomcat compiled those jsp pages on demand and stored them into the cache. Those compiled pages were served also when the original jsp pages go updated by an erratum rpm.
-Consequence:
-The user didn't see a change in the API documentation after applying of erratum with API changes.
-Fix:
-Shipping pre-compiled API documentation.
-Result:
-The user sees API documentation that corresponds to the actual API capabilities.
Comment 9 errata-xmlrpc 2011-11-15 09:08:02 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2011-1452.html

Note You need to log in before you can comment on or make changes to this bug.