Bug 75283 - first-fit routine overlaps windows with the panel
first-fit routine overlaps windows with the panel
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: metacity (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-06 15:19 EDT by Jan "Yenya" Kasprzak
Modified: 2007-04-18 12:47 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-04 01:17:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan "Yenya" Kasprzak 2002-10-06 15:19:50 EDT
Description of Problem:
Metacity places windows below the Gnome panel even though there is plenty of
space on the desktop.

Version-Release number of selected component (if applicable):
metacity-2.4.0.92-5

Steps to Reproduce:
Run several windows of Gnome-terminal (I have 1280x1024 screen, and the
font in gnome-terminal that allows me to place two terminals in a row).
However, when I click three times on the terminal launcher (with a clean
workspace), the three windows gets created in a column, with the third one
being partly obscured by the GNOME panel.

Expected Results:
I expect metacity to place windows on the free places first, and only
when the workspace is full it can place the windows above each other.

Additional Information:
I find a RedHat 8.0 GNOME configuration quite disappointing - for example I did
not manage to change the WM from metacity to sawfish (even though the sawfish
configuration is available under the "preferences" menu, which is quite
inconsistent for me), I don't know how to "lower window" or "maximize vertical"
my gnome-terminal in metacity. It seems the configurability and power
of the GNOME desktop for power users has been sacrified for the
"nice first look" of the newbie user. The menu does not contain the "tear off"
line, etc. I hope Ximian did not cripple their GNOME 2.0 distribution
this way, or will I have to switch to KDE or something :-(
Comment 1 Havoc Pennington 2002-10-06 15:29:50 EDT
I can reproduce this, moving bug to http://bugzilla.gnome.org/show_bug.cgi?id=95014

Closing here.
Comment 2 Jan "Yenya" Kasprzak 2003-05-27 12:12:34 EDT
Just a side note: The situation is the same under RedHat 9.
However, I've returned to sawfish so this problem does not bother me
anymore.
Comment 3 Alan Cox 2003-09-24 11:33:24 EDT
Still true in Fedora beta
Comment 4 Havoc Pennington 2003-09-24 18:00:44 EDT
This may have fixed (not built in Rawhide yet):

2003-09-19  Rob Adams <readams@readams.net>

	Fix a bug with partial-width panel struts caused by incorrect
	computation of rectangle widths, and another when using different
	screen resolutions on xineramas.  See #122404.  Also fix a crash
	bug with the MRU list when sticking and unsticking windows.  See
	#120809.
	
	* src/constraints.c (get_outermost_onscreen_positions): Fix
	off-by-one error with partial-width struts.

	* src/window.c (meta_window_update_struts): Fix off-by-one error
	with partial-width struts.
	(meta_window_stick): assign back to GList after g_list_append
	(meta_window_unstick): assign back to GList after g_list_append
	
	* src/workspace.c (ensure_work_areas_validated): For right and
	bottom struts, compute strut relative to root window and not to
	xinerama edge in compliance with EWMH recommendations.
Comment 5 Havoc Pennington 2003-10-04 01:17:38 EDT
If not fixed please reopen http://bugzilla.gnome.org/show_bug.cgi?id=95014

Note You need to log in before you can comment on or make changes to this bug.