Bug 75288 - Laptop resume hangs computer
Laptop resume hangs computer
Status: CLOSED DUPLICATE of bug 75278
Product: Red Hat Linux
Classification: Retired
Component: apmd (Show other bugs)
8.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Bill Nottingham
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-06 16:55 EDT by sitongia
Modified: 2015-01-07 19:00 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:49:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sitongia 2002-10-06 16:55:11 EDT
From Bugzilla Helper: 
User-Agent: Mozilla/5.0 (compatible; Konqueror/3; Linux) 
 
Description of problem: 
Under RH 7.3, my Dell Inspiron 4100 could suspend and resume 
while X was running with the lid closing and opening.  Now, under 8, it hangs 
the whole computer up.  The keyboard is unresponsive. 
 
Under 7.3, I had the stock XFree86, plus an early-access X driver 
for the Radeon graphics from the driver author.  That fixed a problem I had 
with resume causing the screen to "melt down" and fixed a nonfunctioning 
option to turn the laptop screen off when and external monitor is connected.  
The author had developed this version of the driver for XF 4.2.  It looks like 
it is now incorporated in the RH 8 release.  The author is hy0@ipoline.com. 
 
There do not appear to be any messages about this in the system log. 
 
 
Version-Release number of selected component (if applicable): 
 
 
How reproducible: 
Always 
 
Steps to Reproduce: 
1.configure BIOS to suspend when lid is shut 
2.shut lid 
3.open lid 
	 
 
Actual Results:  The fan goes on and it sounds like the system is going to 
start up.  The screen stays blank, and the keyboard is unresponsive (caps 
lock, for example).  Cannot reboot or halt computer.  Cannot kill X session.  
Have to power-cycle. 
 
Expected Results:  session resumes normally. 
 
Additional info:
Comment 1 Dave 2002-10-07 18:49:40 EDT
I also have this problem with RH8 on my laptop (Dell Latitude C800, ATI Mobility
M4), although I never installed RH7.3 on the computer.  I cannot successfully
suspend to disk nor suspend to RAM.
Comment 2 Brett Porter 2002-10-18 00:51:15 EDT
Inspiron 4000; same. Works if I set apmd setuid and use "Suspend" from the gnome
panel battery applet, but not if I shut the lid.

Well, it did. I upgraded to kernel 2.4.18-17 today and suspend doesn't power off
the machine any more. This only happens when the ethernet card is in. Just filed
a new bug 76206.
Comment 3 Need Real Name 2002-11-19 11:04:26 EST
I have similar behaviour on my Dell Latitude L400.

The strange thing is that it hangs on the *second* resume, the first 
suspend/resume works fine.  This is 100% repeatable.  It happens whether or 
not apmd is running, whether or not X is running, and none of the kernel 
configuration options related to APM have any effect.
Comment 4 Bill Nottingham 2003-05-19 16:41:24 EDT

*** This bug has been marked as a duplicate of 75278 ***
Comment 5 Red Hat Bugzilla 2006-02-21 13:49:46 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.