Bug 752885 - Home directories for system accounts adm, uucp and gopher do not exist
Home directories for system accounts adm, uucp and gopher do not exist
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: setup (Show other bugs)
rawhide
All Linux
unspecified Severity low
: ---
: ---
Assigned To: Ondrej Vasik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-10 12:52 EST by DaveG
Modified: 2011-11-11 10:55 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-11-11 10:55:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description DaveG 2011-11-10 12:52:09 EST
Description of problem:
The default /etc/passwd includes accounts 'adm', 'uucp' and 'gopher' with home directories that are not included in the package.

Version-Release number of selected component (if applicable):
setup-2.8.28-2.fc14.noarch
(Still in git HEAD)

How reproducible:
+++
# uname -r
⏎
2.6.35.14-103.fc14.x86_64
# pwck⏎
user 'adm': directory '/var/adm' does not exist

user 'uucp': directory '/var/spool/uucp' does not exist

user 'gopher': directory '/var/gopher' does not exist

pwck: no changes


# yum whatprovides '/var/adm'⏎
No Matches found


# yum whatprovides '/var/spool/uucp'⏎
uucp-1.07-23.fc14.x86_64 : A set of utilities for operations between systems

Repo        : fedora

Matched from:

Filename    : /var/spool/uucp


# yum whatprovides '/var/gopher'⏎
No Matches found

---

Additional info:
Please consider including the various home directories in the base installation package set (filesystem?) or move user account creation to the relevant service packages. Just trying to reduce the background noise from system integrity checks.
Comment 1 Ondrej Vasik 2011-11-10 15:57:50 EST
Thanks for the report, I'll check these accounts and the reasons why they should be created by default. If this is really necessary, than filesystem package should create these dirs...
Comment 2 Ondrej Vasik 2011-11-11 10:55:39 EST
Directories for system accounts from setup now owned and created by filesystem package ( /var/spool/uucp directory ownership dropped from uucp package , homedir in /usr/share/doc/setup-*/uidgid file for gopher changed to /var/gopher to match with /etc/passwd) . Fixed in setup-2.8.43-1.fc17 , closing Rawhide.

Note You need to log in before you can comment on or make changes to this bug.