Bug 75295 - Unresolved symbols when loading bttv kernel module
Unresolved symbols when loading bttv kernel module
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
8.0
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-06 19:52 EDT by Josi Romildo Malaquias
Modified: 2007-04-18 12:47 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-04-05 11:35:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Josi Romildo Malaquias 2002-10-06 19:52:40 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020809

Description of problem:
I have a PixelView Play TV Pro card installed in my computer
and it was running correctly with Red Hat Linux 7.3.

After installing the 8.0 version, I cannot successfuly run
xawtv anymore and it write the messages:

# xawtv
This is xawtv-3.74, running on Linux/i686 (2.4.18-14)
can't open /dev/video0: No such device
v4l2: open /dev/video0: No such device
v4l: open /dev/video0: No such device
no video grabber device available

Looking at /var/log/messages I see that bttv.o failed
loading. Trying to manually load the bttv module gives
unresolved symbol messages:

# insmod bttv
Using /lib/modules/2.4.18-14/kernel/drivers/media/video/bttv.o
/lib/modules/2.4.18-14/kernel/drivers/media/video/bttv.o: unresolved symbol
video_unregister_device_R13dcb4bc
/lib/modules/2.4.18-14/kernel/drivers/media/video/bttv.o: unresolved symbol
i2c_bit_del_bus_R88f4afaf
/lib/modules/2.4.18-14/kernel/drivers/media/video/bttv.o: unresolved symbol
video_register_device_Rb2927b1b
/lib/modules/2.4.18-14/kernel/drivers/media/video/bttv.o: unresolved symbol
i2c_bit_add_bus_R933524db


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Configure /etc/modules.conf with respect to the bttv.o module
2. Run the command "insmod bttv.o"
3.
	

Actual Results:  The bttv.o kernel module is not loaded. The command shows the
following messages:

Using /lib/modules/2.4.18-14/kernel/drivers/media/video/bttv.o
/lib/modules/2.4.18-14/kernel/drivers/media/video/bttv.o: unresolved symbol
video_unregister_device_R13dcb4bc
/lib/modules/2.4.18-14/kernel/drivers/media/video/bttv.o: unresolved symbol
i2c_bit_del_bus_R88f4afaf
/lib/modules/2.4.18-14/kernel/drivers/media/video/bttv.o: unresolved symbol
video_register_device_Rb2927b1b
/lib/modules/2.4.18-14/kernel/drivers/media/video/bttv.o: unresolved symbol
i2c_bit_add_bus_R933524db



Expected Results:  Loading the bttv.o kernel module.

Additional info:

I have a PixelView Play TV Pro card installed in my computer
and it was running correctly with Red Hat Linux 7.3.
Comment 1 Arjan van de Ven 2002-10-07 03:53:42 EDT
please use "modprobe" and not "insmod". "insmod" doesn't take care of depencies,
in this case the video4linux module needs to have loaded before the bttv one ;(
Comment 2 Josi Romildo Malaquias 2002-10-07 05:52:41 EDT
Result of running modprobe:

# modprobe -v bttv
/sbin/insmod /lib/modules/2.4.18-14/kernel/drivers/i2c/i2c-algo-bit.o bit_test=1
Using /lib/modules/2.4.18-14/kernel/drivers/i2c/i2c-algo-bit.o
Symbol version prefix ''
/sbin/insmod /lib/modules/2.4.18-14/kernel/drivers/media/video/videodev.o
Using /lib/modules/2.4.18-14/kernel/drivers/media/video/videodev.o
/sbin/insmod /lib/modules/2.4.18-14/kernel/drivers/media/video/bttv.o card=37
autoload=1 pll=1 tuner=2 irq_debug=1 radio=1 bttv_verbose=2
Using /lib/modules/2.4.18-14/kernel/drivers/media/video/bttv.o
/lib/modules/2.4.18-14/kernel/drivers/media/video/bttv.o: init_module: No such
device
Hint: insmod errors can be caused by incorrect module parameters, including
invalid IO or IRQ parameters.
      You may find more information in syslog or the output from dmesg
/lib/modules/2.4.18-14/kernel/drivers/media/video/bttv.o: insmod
/lib/modules/2.4.18-14/kernel/drivers/media/video/bttv.o failed
# delete videodev
# delete i2c-algo-bit
/lib/modules/2.4.18-14/kernel/drivers/media/video/bttv.o: insmod bttv failed


I found the following in dmesg:

i2c-algo-bit.o: i2c bit algorithm module
Linux video capture interface: v1.00
bttv: driver version 0.7.91 loaded
bttv: using 2 buffers with 2080k (4160k total) for capture
bttv: Host bridge is VIA Technologies, Inc. VT8367 [KT266]
Comment 3 Josi Romildo Malaquias 2002-10-14 18:03:45 EDT
After looking at the hardware, I have discovered the tv card was not firmly
attached to the PCI slot in the motherboard. Correcting this solved the problem.

Note You need to log in before you can comment on or make changes to this bug.