Bug 75304 - bdist_rpm fails due to "rpm" build options moving to "rpmbuild".
bdist_rpm fails due to "rpm" build options moving to "rpmbuild".
Status: CLOSED NEXTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: python (Show other bugs)
8.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mihai Ibanescu
Brock Organ
:
: 79243 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-07 00:34 EDT by jafo-redhat
Modified: 2007-04-18 12:47 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-04 16:39:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description jafo-redhat 2002-10-07 00:34:20 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020809

Description of problem:
The RH8.0 release, the "-ba" and similar build options have been
moved out of the "rpm" command into the "rpmbuild" command only.
The distutils code for the "bdist_rpm" sub-command fails because
of this.

I have put up patch #619493 at sourceforge.net which fixes this
issue.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Download and unpack a Distutils-packaged Python module (for
   example:
ftp://ftp.tummy.com/pub/tummy/Python/python-chap/python-chap-1.13.tar.gz)
2. Run "python setup.py bdist_rpm"

Actual Results:  Fails to produce binary/source RPMs with the results:

[...]
building RPMs
rpm -ba --define _topdir /tmp/python-chap-1.13/build/bdist.linux-i686/rpm
--clean build/bdist.linux-i686/rpm/SPECS/python-chap.spec
-ba: unknown option
error: command 'rpm' failed with exit status 1


Expected Results:  Should produce binary and/or source RPMs

Additional info:
Comment 1 Mihai Ibanescu 2002-11-25 18:47:44 EST
Fixed in python 2.2.2, check out
ftp://people.redhat.com/misa/fixes/python
Comment 2 Mihai Ibanescu 2002-12-08 12:42:14 EST
*** Bug 79243 has been marked as a duplicate of this bug. ***
Comment 3 Bill Nottingham 2006-08-04 16:39:20 EDT
Red Hat Linux and Red Hat Powertools are currently no longer supported by Red
Hat, Inc. In an effort to clean up bugzilla, we are closing all bugs in MODIFIED
state for these products.

However, we do want to make sure that nothing important slips through the
cracks. If, in fact, these issues are not resolved in a current Fedora Core
Release (such as Fedora Core 5), please open a new issues stating so. Thanks.

Note You need to log in before you can comment on or make changes to this bug.