Bug 753056 - API kickstart.keys.delete does not affect cobbler records
API kickstart.keys.delete does not affect cobbler records
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: API (Show other bugs)
541
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tomas Lestach
Martin Korbel
:
Depends On:
Blocks: sat560-api
  Show dependency treegraph
 
Reported: 2011-11-11 03:03 EST by Šimon Lukašík
Modified: 2013-10-01 17:44 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 17:44:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Šimon Lukašík 2011-11-11 03:03:50 EST
Description of problem:
The call of kickstart.keys.delete may affect content of kickstart files.

When a given key was assigned to kickstart files, these kickstart files
needs to regenerated. Currently, cobbleer-rendered kickstarts are
not regenerated.

Version-Release number of selected component (if applicable):
RHN Satellite 5.4.1+
spacewalk-java-1.2.39-108

How reproducible:
deterministic

Steps to Reproduce:
1. Create a kickstart profile (kickstart.createProfile)
2. Create SSL or GPG key (kickstart.keys.create)
3. assign key to the kickstart (kickstart.profile.system.addKeys)
4. verify that ks in cobbler gets populated
   (kickstart.profile.downloadRenderedKickstart)
5. delete the SSL or GPG key (kickstart.keys.delete)
6. repeat step 4.
  
Actual results:
Key remains contained in cobbler-rendered ks file.

Expected results:
Key is not contained in cobbler-rendered ks files.

Additional info:
Comment 3 Tomas Lestach 2012-07-25 10:19:17 EDT
Valid bug ...

spacewalk.git: b589eeadcb382fdcbc299dcd89cc6051a97327be
Comment 6 Clifford Perry 2013-10-01 17:40:40 EDT
Satellite 5.6 has been released. This bug was tracked under the release.  

This bug was either VERIFIED or RELEASE_PENDING (re-verified prior shortly
before release). 

Moving to CLOSED CURRENT_RELEASE. 

Text from Upgrade Erratum follows:

Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1395.html

Note You need to log in before you can comment on or make changes to this bug.