Bug 753079 - logrotate complains about cacti
Summary: logrotate complains about cacti
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: cacti
Version: 16
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Gwyn Ciesla
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-11-11 09:35 UTC by Tom Hughes
Modified: 2011-11-25 04:04 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-11-25 04:04:48 UTC
Type: ---


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 680799 0 high CLOSED logrotate: Improper administration of log files located in world-writable directories 2021-02-22 00:41:40 UTC

Internal Links: 680799

Description Tom Hughes 2011-11-11 09:35:43 UTC
Description of problem:

When logrotate runs on a machine with cacti installs it complains about the ownership of the cacti logs.

Version-Release number of selected component (if applicable):

cacti-0.8.7g-2.fc15

How reproducible:

Every time logrotate runs.

Steps to Reproduce:
1. Run logrotate
2. See the error
  
Actual results:

error: skipping "/var/log/cacti/cacti.log" because parent directory has insecure permissions (It's world writable or writable by group which is not "root") Set "su" directive in config file to tell logrotate which user/group should be used for rotation.

Expected results:

Silence.

Comment 1 Ken Dreyer 2011-11-11 15:59:40 UTC
Thanks, fixed in rawhide, via commit 77ee32e40c802e881bb7048e9d116578ec2d83cc . Koji is building cacti-0.8.7h-2.fc17 currently.

Are you using F15 or F16?

Comment 2 Tom Hughes 2011-11-11 16:01:18 UTC
I'm using F16 - the noise appeared after upgrading from F15.

Comment 3 Fedora Update System 2011-11-11 16:16:12 UTC
cacti-0.8.7h-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/cacti-0.8.7h-2.fc16

Comment 4 Ken Dreyer 2011-11-14 04:35:55 UTC
Thanks for the feedback in Bodhi.

Comment 5 Fedora Update System 2011-11-25 02:25:47 UTC
cacti-0.8.7h-2.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.