Bug 753090 - eclipse-jdt-3.7.1-1 broken
eclipse-jdt-3.7.1-1 broken
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Roland Grunberg
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-11 05:19 EST by Sandro Mani
Modified: 2011-11-21 17:53 EST (History)
10 users (show)

See Also:
Fixed In Version: eclipse-3.7.1-4.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-11-21 17:53:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sandro Mani 2011-11-11 05:19:13 EST
Description of problem:

Upgrade fails:
[...]
Error unpacking rpm package 1:eclipse-jdt-3.7.1-1.fc16.x86_64
error: unpacking of archive failed on file /usr/bin/efj: cpio: rename
Version-Release number of selected component (if applicable):
[...]

Java development broken after clean install of eclipse 3.7.1 packages:
- After lauch, main window shows:
Could not open the editor: No editor descriptor for id org.eclipse.jdt.ui.CompilationUnitEditor
- File -> New: no entry for Java project

How reproducible:
Always

Affected versions:
eclipse-jdt-3.7.1-1.fc16.x86_64
Comment 1 Alexander Kurtakov 2011-11-11 09:46:57 EST
Sami, would you please take a look ?
Comment 2 Matthias Runge 2011-11-11 15:30:05 EST
Additional, this upgrade breaks eclipse-pydev
Comment 3 Sami Wagiaalla 2011-11-14 12:31:55 EST
I am looking into this. It is a reconciliation issue.
Comment 4 Fedora Update System 2011-11-17 14:16:25 EST
eclipse-3.7.1-3.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/eclipse-3.7.1-3.fc16
Comment 5 Samuel Sieb 2011-11-17 14:54:57 EST
I got the following when doing the upgrade:

Error unpacking rpm package 1:eclipse-jdt-3.7.1-3.fc16.i686
error: unpacking of archive failed on file /usr/bin/efj: cpio: rename

It appears to be due to changing from a directory to a file.  I deleted that directory and tried the upgrade again.  It succeeded and eclipse works properly.
Comment 6 Andrew Overholt 2011-11-17 15:17:09 EST
Alex, did we have some workaround for this directory -> file change in the past?
Comment 7 Alexander Kurtakov 2011-11-17 16:58:53 EST
Yes, we do. It's fixed properly on rawhide and Roland is aware of it.
Comment 8 Fedora Update System 2011-11-18 10:27:58 EST
eclipse-3.7.1-4.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/eclipse-3.7.1-4.fc16
Comment 9 Samuel Sieb 2011-11-18 11:07:57 EST
That one works and upgraded with no errors.
Comment 10 Fedora Update System 2011-11-19 01:01:52 EST
Package eclipse-3.7.1-4.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing eclipse-3.7.1-4.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-16108/eclipse-3.7.1-4.fc16
then log in and leave karma (feedback).
Comment 11 Fedora Update System 2011-11-21 17:53:40 EST
eclipse-3.7.1-4.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.