Bug 753158 - spacewalk-repo-sync fails when downloading more than 1013 files
spacewalk-repo-sync fails when downloading more than 1013 files
Status: CLOSED ERRATA
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
541
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: Michael Mráka
Jan Hutař
:
Depends On:
Blocks: sat541-triage
  Show dependency treegraph
 
Reported: 2011-11-11 08:39 EST by Dimitar Yordanov
Modified: 2012-03-08 04:06 EST (History)
3 users (show)

See Also:
Fixed In Version: spacewalk-backend-1.2.13-58
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-11-21 04:45:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Michael Mráka 2011-11-14 03:33:24 EST
This bug has been fixed in spacewalk some time ago, see bug 695236.
Comment 2 Michael Mráka 2011-11-14 05:23:06 EST
Backported changes to SATELLITE-5.4 as
commit 983a83b5702112905857f52ae309e60b325ac59a
    fd's for already seen packages should be also closedcommit 23f294f3ce76c8c8ae763d6f762c7f0525a501c8
    fixed leaked filedescriptor in reposync
    addressing
    python: ./rpmio_internal.h:502: c2f: Assertion `fd && fd->magic == 0x04463138' faile
    ORA-24550: signal received: [si_signo=6] [si_errno=0] [si_code=-6] [si_int=4202816] 
    kpedbg_dmp_stack()+297<-kpeDbgCrash()+75Cannot open /usr/lib/oracle/11.2/client/lib/
    <-075E6CC1Cannot open /usr/lib/oracle/11.2/client/lib/libclntsh.so.11.1 for reading:
    <-07377F6F<-gsignal()+80<-abort()+257<-__assert_fail()+251Cannot open /usr/lib/librp
    (cherry picked from commit 12a42dcc950b03d0dd6871689b00954d18a34ddc)
Comment 5 errata-xmlrpc 2011-11-21 04:45:10 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1466.html

Note You need to log in before you can comment on or make changes to this bug.