Bug 75317 - Installer exited abnormally
Installer exited abnormally
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
8.0
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-07 04:41 EDT by Paul Farrar
Modified: 2007-04-18 12:47 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-21 07:34:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Farrar 2002-10-07 04:41:05 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 4.0)

Description of problem:
When running a boot floppy to install Redhat Linux 8.0 the installer exits 
abnormally. The installer always gets past the CDROM checking. It exits at 
different stages each time, although has never managed to choose packages. The 
error occurs with the text and graphical installers. Sometimes an unhandled 
exception occurs although I have been unable to capture the text of this.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Load either graphical or text installer from boot floppy.
2. Pass checking of CDROM.
3. Installer will exit at some point before choosing packages or will freeze 
when the "choose packages" screen is shown.
	

Actual Results:  Running anaconda the RedHat Linux system installer please wait.
Traceback (most recent call last): file "/usr/bin/anaconda" line 70 in ?
import signal traceback string isys iutil time file "/usr/lib/anaconda/isys.py" 
line 18 in ? import_sys import error:/lib/libresolv.so.2:cannot read file data: 
is a directory
Install exited abnormally 
sending termination signals done
sending kill signals done
disabling swap
unmounting file systems
/mnt/runtime done
disabling /dev/loop0/proc done
/dev/pts done
/mnt/source done
You may safely reboot.


Expected Results:  Installer to continue

Additional info:

I am trying to install on an old Pentium 100MHz. It has an 8 speed CDROM drive. 
2 harddisks, a 1GB & a 1.6GB. 48MB RAM, 4 * 72 pin SIMS (2* 4MB, 2* 16MB). Has 
a Redhat recognises the GFX card as a Cirrus Logic card, it is based on the 
motherboard. Also has a PCI sound card, PCI network card, and an ISA modem. The 
machine is an old Packard Bell. I intend to use it as a router.
Comment 1 Paul Farrar 2002-10-07 04:45:12 EDT
I forgot to mention. The install media in the CDROM is checked and passes. I 
checked the iso images with md5sum before I burnt them.
Comment 2 Paul Farrar 2002-10-07 05:08:22 EDT
I forgot to mention. The install media in the CDROM is checked and passes. I 
checked the iso images with md5sum before I burnt them.
Comment 3 Jeremy Katz 2002-10-07 17:04:19 EDT
This is usually a symptom of hardware problems if hte mediacheck passes.  Could
you run memtest86 to verify that your memory is good?
Comment 4 Paul Farrar 2002-10-08 05:41:24 EDT
There is currently no OS on the machine. How do I run memtest86? Can I make a 
boot from the Redhat CDs? I think that the error that was occuring under the 
text only install is/was a different error. The text installer seems to be ok 
if I use the "specdd" command to disable the monitor probing. The graphical one 
still fails though. Thanks for the help.
Comment 5 Jeremy Katz 2002-10-09 11:26:12 EDT
memtest86 is a stand-alone program which is run from a floppy; you can download
it from http://www.memtest86.com
Comment 6 Paul Farrar 2002-10-21 07:34:17 EDT
I have tried memtest86 with all tests. No errors were reported.
Comment 7 Michael Fulbright 2002-10-24 15:02:19 EDT
I believe you will need more RAM to install 8.0.

Note You need to log in before you can comment on or make changes to this bug.