Bug 753196 - KDM crashes when interacting with XDMCP chooser
Summary: KDM crashes when interacting with XDMCP chooser
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kdebase-workspace
Version: 16
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Than Ngo
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-11-11 15:15 UTC by Dr. Tilmann Bubeck
Modified: 2012-09-07 20:33 UTC (History)
9 users (show)

Fixed In Version: 4.8.5
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-09-07 06:07:12 UTC
Type: ---


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
KDE Software Compilation 281862 None None None Never

Description Dr. Tilmann Bubeck 2011-11-11 15:15:51 UTC
Description of problem:
When selecting 'remote login' in kdm and moving the mouse above the chooser
window the X server restarts, showing the login screen again.

/var/log/messages showed:

Sep 12 11:28:21 (none) kdm: :0[1399]: Received unknown command 4 from greeter

Reproducible: Always

Steps to Reproduce:
Start KDM
Select "remote login"
Move the mouse in the chooser window

Actual Results:  
X server/kdm restarts

Expected Results:  
selecting remote host possible

Comment 1 Dr. Tilmann Bubeck 2012-03-20 13:47:31 UTC
The following workaround has been found upstreams in the references KDE bug tracker:

"FYI Gentoo has resolved this successfully by reverting kdm commit 720b0bfe5fab7142b9683f329b75cf2951b95c8e"

Comment 2 Dr. Tilmann Bubeck 2012-09-07 06:07:12 UTC
Fixed upstreams with KDE 4.8.5 and therefore also fixed in Fedora since KDE 4.8.5.


Note You need to log in before you can comment on or make changes to this bug.