Bug 753219 - Fedora 16 initrd hangs on Dell XPS 630
Summary: Fedora 16 initrd hangs on Dell XPS 630
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 16
Hardware: i686
OS: Linux
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Fedora Extras Quality Assurance
Depends On:
TreeView+ depends on / blocked
Reported: 2011-11-11 16:14 UTC by Roger Noble
Modified: 2015-01-04 22:31 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2012-09-05 13:50:56 UTC
Type: ---

Attachments (Terms of Use)
dmesg output with acpi=off (50.38 KB, text/plain)
2011-11-12 11:46 UTC, Roger Noble
no flags Details

Description Roger Noble 2011-11-11 16:14:34 UTC
Description of problem:

initrd hangs on installation, preupgrade and Live versions of Fedora 16 on a
Dell XPS 630 (8 GB). Fedora 16 cannot be installed.

The last thing monitored is:

rtc_cmos 00:05: setting system clock to ... (etc)

Version-Release number of selected component (if applicable):

How reproducible:

Every time.

Steps to Reproduce:
1. Insert Live CD or installation media
2. Select run or install
3. Wait
Actual results:

System hangs.

Expected results:

System to continue and boot.

Additional info:

Comment 1 Roger Noble 2011-11-12 11:46:11 UTC
Created attachment 533232 [details]
dmesg output with acpi=off

Comment 2 Roger Noble 2011-11-12 11:52:37 UTC
I've chased this one a bit more. I can get it past the "setting system clock" line but only by setting acpi=off. But the resultant running Live OS won't load nouveau for my Nvidia graphics adaptor, claiming that there is no such device. No other kernel boot parameter I've tried gets it past "setting system clock".

It all worked fine with the latest kernel in Fedora 15, and F16 works fine on my (Dell) laptop, also with Nvidia graphics.

Comment 3 Roger Noble 2011-11-12 18:21:24 UTC
OK, I've managed to work round the problem (I hope). The clue was the following line in dmesg immediately following the "setting system clock":

[    1.175853] p4-clockmod: Warning: EST-capable CPU detected. The acpi-cpufreq module offers voltage scaling in addition to frequency scaling. You should use that instead of p4-clockmod, if possible.

And noting that F16 had changed the way that cpu frequency/voltage scaling was done.

Disabled cpu frequency/voltage scaling in the BIOS fixed the hang and enabled the Live OS to run, but there is obviously a problem with F16 and the Dell BIOS? in this area.

Comment 4 Ferry Huberts 2011-12-09 14:55:00 UTC
Same issue on a Lenovo W520 4284-4MG system with 16GB

Comment 5 Ferry Huberts 2011-12-09 16:54:47 UTC
really annoying bug, since most stuff like BT and Fn keys do not work now since acpi is disabled

how can I disable p4-clockmod on the kernel commandline?

Comment 6 Ferry Huberts 2011-12-09 17:08:02 UTC
oh, suspend also doesn't work...
I bet there's more I haven't yet discovered ;-)

I'm on x86_64, F16
CPU Intel i7 2860QM, 16GB memory

Comment 7 Ferry Huberts 2011-12-09 17:52:35 UTC
and my 4 core / 2 threads cpu is now turned into a single core... ;-(

Comment 8 Ferry Huberts 2011-12-12 17:23:56 UTC
I followed the instructions on http://fedoraproject.org/wiki/Building_a_custom_kernel to build a kernel without the p4-clockmod module, but I'm getting an error during installation of the resulting rpms:

$ su -c "rpm -ivh --force kernel-3.1.4-1.ferry.no.p4.clockmod.fc16.x86_64.rpm kernel-firmware-3.1.4-1.ferry.no.p4.clockmod.fc16.x86_64.rpm kernel-headers-3.1.4-1.ferry.no.p4.clockmod.fc16.x86_64.rpm kernel-devel-3.1.4-1.ferry.no.p4.clockmod.fc16.x86_64.rpm"
error: Failed dependencies:
	kernel-firmware < 20110731 is obsoleted by (installed) linux-firmware-20110731-2.fc16.noarch

* dazed and confused now *

Comment 9 Ferry Huberts 2011-12-12 18:24:22 UTC
this turned out to be *too* easy: simply add to the grub kernel commandline "rd.driver.blacklist=p4-clockmod"

Comment 10 Ferry Huberts 2011-12-12 18:32:38 UTC
(In reply to comment #9)
> this turned out to be *too* easy: simply add to the grub kernel commandline
> "rd.driver.blacklist=p4-clockmod"

strike that. that didn't work :-(

Comment 11 Ferry Huberts 2011-12-12 18:55:13 UTC
(In reply to comment #9)
> this turned out to be *too* easy: simply add to the grub kernel commandline
> "rd.driver.blacklist=p4-clockmod"

it appears this sometimes works for me.
I tried a suspend, didn't work and then this fix also didn't work anymore. had to pull the battery and power supply, re-attach power supply and then the fix worked again.

I'm a bit surprised that this driver is compiled in since its documentation in the kernel 'make xconfig' is rather explicit about using it only 'in exceptional circumstances'

Comment 12 Ferry Huberts 2011-12-12 19:19:39 UTC
did some more experiments:
- it only works if I boot _without_ the battery
- switching from discrete nvidia quadro 2000M gfx hw to internal intel 3000 gfx hw makes it all work: acpi, suspend, bt, the works.

so there appears to be some kind of hardware init problem somewhere?

Comment 13 Ferry Huberts 2012-01-03 09:52:14 UTC

Comment 14 Roger Noble 2012-04-07 17:40:35 UTC
I've tried this again with the Dell XPS 630 with frequency/voltage scaling enabled in the BIOS and using kernels 3.3.0-8 and 3.3.1-2 and the problem appears to have been fixed. Maybe fixed with some earlier kernels as well but I did not check those.

Comment 15 Josh Boyer 2012-04-09 13:29:22 UTC
Ferry, do you have similar results as Roger in comment #14?

Comment 16 Ferry Huberts 2012-04-09 14:11:00 UTC
I tried, but no matter what display configuration I chose in the BIOS, if I enabled the Nvidia card, the kernel hangs hard during boot on 
'wmi: Mapper loaded'

I'm booting without any special options, all default:

menuentry 'Fedora (3.3.1-3.fc16.x86_64)' --class fedora --class gnu-linux --class gnu --class os {
	set gfxpayload=keep
	insmod gzio
	insmod part_msdos
	insmod ext2
	set root='(hd0,msdos1)'
	search --no-floppy --fs-uuid --set=root c4d60bd8-de36-4e75-b679-f8707cac4a96
	echo 'Loading Fedora (3.3.1-3.fc16.x86_64)'
	linux	/vmlinuz-3.3.1-3.fc16.x86_64 root=/dev/mapper/vg_stinkpadw520-lv_root ro rd.lvm.lv=vg_stinkpadw520/lv_swap rd.md=0 rd.dm=0 rd.luks.uuid=luks-29a52a86-a488-4105-81ac-5fa5e777d4d8 rd.lvm.lv=vg_stinkpadw520/lv_root  KEYTABLE=us SYSFONT=latarcyrheb-sun16 LANG=en_US.UTF-8 quiet
	echo 'Loading initial ramdisk ...'
	initrd /initramfs-3.3.1-3.fc16.x86_64.img

Comment 17 Josh Boyer 2012-09-05 13:50:56 UTC
(In reply to comment #16)
> I tried, but no matter what display configuration I chose in the BIOS, if I
> enabled the Nvidia card, the kernel hangs hard during boot on 
> 'wmi: Mapper loaded'

That isn't the same problem Roger reported.  It sounds like an issue with nouveau locking up, not a cpufreq issue.  Please open a separate bug for that.

Closing per Roger's comments.

Note You need to log in before you can comment on or make changes to this bug.