This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 753273 - rsyslog configuration causes messages log to grow rapidly
rsyslog configuration causes messages log to grow rapidly
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-configure (Show other bugs)
1.0.0
x86_64 Linux
unspecified Severity high
: rc
: ---
Assigned To: Jason Guiditta
wes hayutin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-11 13:28 EST by Brad P. Crochet
Modified: 2012-05-15 16:43 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-15 16:43:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Brad P. Crochet 2011-11-11 13:28:58 EST
Description of problem:
It appears that there is some type of circular logging problem occurring with the 
rsyslog configuration of aeolus.

When both of these are enabled (which is the default and in puppet):

# setup relp server
$ModLoad imrelp
$InputRELPServerRun 20514

# setup relp client
$ModLoad omrelp
*.* :omrelp:localhost:20514;RSYSLOG_ForwardFormat

The logs grow extremely rapidly, quickly filling up whatever filesystem the logs are on.

When either one is commented out, the logs stop growing out of control, and return to a normal pace.

Version-Release number of selected component (if applicable):
[root@qeblade33 rsyslog.d]# rpm -qa | grep aeolus-configure
aeolus-configure-2.3.0-0.20111110143552git219f023.fc15.noarch


How reproducible:
Consistently

Steps to Reproduce:
1. Install aeolus-configure
2. Run aeolus-configure (any configuration will do)
3.
  
Actual results:
Logs growing rapidly

Expected results:
Log don't grow rapidly

Additional info:
Comment 1 wes hayutin 2011-11-11 14:01:39 EST
this seems to be filling up our / partitions .. making this blocker
Comment 3 Jason Guiditta 2011-11-11 17:06:35 EST
commit dc6726982792e7026773a8a2f33d75bf3e47da74
Author: Jason Guiditta <jguiditt@redhat.com>
Date:   Fri Nov 11 16:49:13 2011 -0500

    BZ 753273 - rsyslog configuration causes messages log to grow rapidly.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=753273
    
    There were a number of small things causing this:
    * We were logging relp output to localhost
    * We were logging it to messages instead of /var/log/aeolus.log
    * There was a syntax error
    * We were spinning up an input relp server on a port that we don't
      yet have an selinux policy for
    
    I fixed the main issues and commented all the enabling bits out. The
    user/admin really needs to put where to output, and they are unlikely
    to actually use the input module, but it is harmless to leave as an
    example.
Comment 4 Brad P. Crochet 2011-11-16 13:07:27 EST
Verified. 

Logs no longer grow out of control. relp is there but disabled.

commit 9bdb7d01
Comment 5 wes hayutin 2011-11-27 20:15:59 EST
removing bugs from ce-sprint from the tracker.. you can find these bugs by querying the "qa whiteboard" for ce-sprint-60
Comment 8 errata-xmlrpc 2012-05-15 16:43:47 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-0586.html

Note You need to log in before you can comment on or make changes to this bug.