Bug 753279 - Apps dlopening libGL directly or indirectly are crashing with F16 and nvidia proprietary driver
Summary: Apps dlopening libGL directly or indirectly are crashing with F16 and nvidia ...
Keywords:
Status: CLOSED DUPLICATE of bug 751891
Alias: None
Product: Fedora
Classification: Fedora
Component: glibc
Version: 16
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Andreas Schwab
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-11-11 18:46 UTC by Sammy
Modified: 2016-11-24 16:11 UTC (History)
15 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-11-14 11:15:07 UTC


Attachments (Terms of Use)

Description Sammy 2011-11-11 18:46:40 UTC
I have just updated my machine from F15 to F16 and facing severe crashes
with the KDE system. I am using kdm and kde solely. One can login but
frequently kde daemons crash leaving a dead workspace with black backgorund.
One can go back to kdm login via ctrl-alt-backspace.

Crashing daemons kded4, krunner, knotify, plasma,....

I have the nouveau driver. I have switched back and forth to nvidia drivers
with the same problem.

I removed my .kde direcory to no avail either. Any help will be appreciated.

Comment 1 Sammy 2011-11-11 19:20:30 UTC
The nouveau driver is much more stable....I am using that now. I did see
the notes about nvidia drivers on F16 notes.

Comment 2 Sammy 2011-11-12 13:45:45 UTC
This looks like the bug bz737223, there glibc was found to be the
culprit and a version of glibc that solves the problem was built
(glibc-2.14.90-12.999) but then higher version of glibc installed.
Do they contain this fix?

Comment 3 Kevin Kofler 2011-11-12 17:37:26 UTC
Please post a stack backtrace to the bug report. I've seen some posted to IRC, and what they had in common was that libGL was getting dlopened by QtOpenGL, and it crashed in the ELF relocation code. It looks like the glibc fix only worked for the directly linked case, but not for the dlopen case, which means that anything using QtOpenGL still crashes.

There's not much we can do about this in kdelibs packaging, it's some issue between glibc and nvidia. I'll leave it to the glibc maintainers to decide whether they can and want to do anything about this. Reassigning.

Comment 4 Kevin Kofler 2011-11-13 22:39:35 UTC
According to the duplicate bug #751891, it looks like this happens even if what's dlopened is not libGL directly, but some plugin which just indirectly links it.

Comment 5 Kevin Kofler 2011-11-13 22:40:48 UTC
*** Bug 751891 has been marked as a duplicate of this bug. ***

Comment 6 Andreas Schwab 2011-11-14 11:15:07 UTC

*** This bug has been marked as a duplicate of bug 751891 ***

Comment 7 Kevin Kofler 2011-11-29 14:16:50 UTC
*** Bug 757599 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.