Bug 7533 - rpm-3.0.3 doesn't compile under solaris
rpm-3.0.3 doesn't compile under solaris
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
6.1
sparc Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-12-03 04:14 EST by Joerg Dorchain
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-12-03 08:20:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joerg Dorchain 1999-12-03 04:14:05 EST
after having sucessfully worked with rpm-2.5.2 under solaris I tried to
build rpm-3.0.3. For now, the problems are related to misc/err.c.
The configure script find out correctly that solaris 2.6 hasn't an err()
function in the system libraries and tries to build it. This fails because
of a lacking features.h that is included by err.c.
After installing a trivial features.h the make process runs until trying to
link dump. This has an unresolved err symbol. This in turn is in
misc/libmisc.a, which is not linked with.
When linking dump manually with libmisc.a, it fails with unresolved symbols
in err.o such as __progname, __set_errno and fputs_unlocked.
Looks like a linux/glibc-ism.
Comment 1 Jeff Johnson 1999-12-03 08:20:59 EST
Um, I think you are using a preliminary version of rpm-3.0.3. Try getting
the final release from ftp.rpm.org -- I ripped out err.h et al before
releasing rpm-3.0.3 for the reasons you describe above.
Comment 2 Joerg Dorchain 1999-12-03 09:02:59 EST
I got it off the RedHat Linux 6.1 SRPM CD. I'll try to download the mentioned
version now.

Note You need to log in before you can comment on or make changes to this bug.