Bug 75331 - sawfish-ui broken font settin
sawfish-ui broken font settin
Status: CLOSED DUPLICATE of bug 80997
Product: Red Hat Linux
Classification: Retired
Component: sawfish (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-07 06:42 EDT by Henrik Brix Andersen
Modified: 2007-04-18 12:47 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:49:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Henrik Brix Andersen 2002-10-07 06:42:45 EDT
Description of Problem:
When setting the default font using 'sawfish-ui' the font setting dialog 
uses a different font notation than what sawfish exspects.

Version-Release number of selected component (if applicable):
sawfish-2.0-4

How Reproducible:
Every time

Steps to Reproduce:
1. Run command 'sawfish-ui'
2. Select the "Appearence" tab (default)
3. Browse for a randomly choosen default font and click ok

Actual Results:
Sawfish can't find the font and defaults to some ugly scriptish font

Expected Results:
Sawfish should use the newly selected font for window titles

Additional Information:
Solution: enter the font manually, either in the "Default Font" text entry 
in sawfish-ui or by adding a line to ~/.sawfish/custom

Example of line added to ~/.sawfish/custom:
(custom-set-typed-variable (quote default-font) (quote "-b&h-luxi 
sans-bold-r-normal-*-*-120-*-*-p-*-iso8859-1") (quote font))
Comment 1 Felipe Alfaro Solana 2002-12-27 14:00:33 EST
For "sawfish-1.2-2" in Phoebe, this is the line I had to add to "custom":

(custom-set-typed-variable (quote default-font) (quote ("xlfd" .
"-adobe-helvetica-medium-r-normal-*-*-120-*-*-p-*-iso8859-1")) (quote font))

Note the "xlfd" and the "dot" before the actual font name.
Comment 2 Havoc Pennington 2003-01-12 23:44:17 EST

*** This bug has been marked as a duplicate of 80997 ***
Comment 3 Red Hat Bugzilla 2006-02-21 13:49:46 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.