Bug 753382 - Failed to install xguest, again, in F16
Failed to install xguest, again, in F16
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: shadow-utils (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Vrabec
Fedora Extras Quality Assurance
:
: 755716 756589 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-12 01:41 EST by Arnold Wang
Modified: 2011-12-30 17:53 EST (History)
8 users (show)

See Also:
Fixed In Version: shadow-utils-4.1.4.3-11.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-30 17:53:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Patch will stop trying to label policy content based on label of /etc/passwd (505 bytes, patch)
2011-11-14 16:43 EST, Daniel Walsh
no flags Details | Diff

  None (edit)
Description Arnold Wang 2011-11-12 01:41:46 EST
Description of problem:
The system failed to install xguest, again, after the issue was fixed in F15. 
[root@mars home]# yum install xguest
Loaded plugins: langpacks, presto, refresh-packagekit
adobe-linux-x86_64                                       |  951 B     00:00     
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package xguest.noarch 0:1.0.10-1.fc16 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package         Arch            Version                  Repository       Size
================================================================================
Installing:
 xguest          noarch          1.0.10-1.fc16            fedora           60 k

Transaction Summary
================================================================================
Install       1 Package

Total download size: 60 k
Installed size: 60 k
Is this ok [y/N]: y
Downloading Packages:
xguest-1.0.10-1.fc16.noarch.rpm                          |  60 kB     00:00     
Running Transaction Check
Running Transaction Test
Transaction Test Succeeded
Running Transaction
Error in PREIN scriptlet in rpm package xguest-1.0.10-1.fc16.noarch
error: %pre(xguest-1.0.10-1.fc16.noarch) scriptlet failed, exit status 1

Failed:
  xguest.noarch 0:1.0.10-1.fc16                                                 

Complete!


Version-Release number of selected component (if applicable):
xguest.noarch 0:1.0.10-1.fc16
Fedora release 16 (Verne)


How reproducible:
yum install xguest

Steps to Reproduce:
1.yum install xguest
2.
3.
  
Actual results:
Error in PREIN scriptlet in rpm package xguest-1.0.10-1.fc16.noarch
error: %pre(xguest-1.0.10-1.fc16.noarch) scriptlet failed, exit status 1


Expected results:

xguest is installed.

Additional info:
My gut feeling is it's caused by the same bug I reported for F15. 
https://bugzilla.redhat.com/show_bug.cgi?id=720870
Comment 1 Daniel Walsh 2011-11-14 16:43:41 EST
Created attachment 533634 [details]
Patch will stop trying to label policy content based on label of /etc/passwd

There are multiple problems here. 

Basically useradd has been changed from execing semanage to using libsemanage.

This exposed a bug in shadow-utils that

This patch should allow useradd to work with upcoming changes in selinux policy.
Comment 2 Miroslav Grepl 2011-11-28 05:07:43 EST
*** Bug 755716 has been marked as a duplicate of this bug. ***
Comment 3 Miroslav Grepl 2011-11-28 07:27:17 EST
*** Bug 756589 has been marked as a duplicate of this bug. ***
Comment 4 Fedora Update System 2011-12-20 05:11:23 EST
shadow-utils-4.1.4.3-11.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/shadow-utils-4.1.4.3-11.fc16
Comment 5 Fedora Update System 2011-12-22 17:39:28 EST
Package shadow-utils-4.1.4.3-11.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing shadow-utils-4.1.4.3-11.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-17296/shadow-utils-4.1.4.3-11.fc16
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2011-12-30 17:53:41 EST
shadow-utils-4.1.4.3-11.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.