Bug 75339 - Installer crashes with unhandled exception while loading packages
Installer crashes with unhandled exception while loading packages
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-07 09:38 EDT by alex.breeze
Modified: 2007-04-18 12:47 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-07 11:37:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Anaconda dump file (68.30 KB, text/html)
2002-10-07 11:37 EDT, alex.breeze
no flags Details

  None (edit)
Description alex.breeze 2002-10-07 09:38:28 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)

Description of problem:
Actually two pretty reproducible problems:
(i) Anaconda gives an error trying to install mailcap and prompts for a 
<return> to try again. After several <returns> installation proceeds;

(ii) The fatal error (unhandled exception) occurs towards the end of CD 1, when 
trying to install texet-fonts.

I know this isn't a new bug. I've looked through the Anaconda buglists for both 
7.2 and 7.3 and this "(16, 'Device or resource busy')" error crops up again and 
again, and very often (with 7.2 at any rate) it happens at the same point, i.e. 
when installing tetex-fonts (the 'favourite' with 7.3 seems to be openjade). 
And in every bug report, it's ascribed to 'bad CD', 'bad media', 'faulty CD 
drive' etc. by the RH folk.

But...it's not that easy to dismiss the problem as due to bad media or faulty 
CD drives. This bug is happening again and again to people with CDs and CD 
drives that function perfectly normally in other situations. It seems to me 
that the problem lies with Anaconda in that it appears to handle CD read 
problems in an ungraceful and intolerant way. The fact that the problem often 
seems to occur at the same point in the installation on diverse systems might 
suggest that there are particular 'challenges' posed to the hardware or 
software at this point and might provide some clues to solving the problem; it 
also gives the lie to the suggestion that random CD or CD-drive errors are at 
the root of things.

Before I fork out (the admittedly very reasonable) fee for 8.0 and try again, 
can you tell me whether the version of Anaconda in 8.0 has been reinforced to 
make it more robust in the face of these CD read problems? Or are there other 
tweaks that can be applied to the system (e.g. in the BIOS) to reduce their 
impact?

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Boot from pcmcia and pcmciadd floppies
2.Run installer (gui or text) from bought CDs
3.Watch the crash for the nth time
	

Actual Results:  No Linux

Expected Results:  Working Linux

Additional info:

Toshiba Portege 3480CT
192MB RAM
Targus PA950 PC card 24x CD-ROM
USB floppy & mouse
RH7.2 Professional boxed media that have been successfully installed on some 
other systems here.
Comment 1 alex.breeze 2002-10-07 11:37:39 EDT
Created attachment 79205 [details]
Anaconda dump file
Comment 2 Jeremy Katz 2002-10-07 17:09:55 EDT
One cause is faulty media, another is a place where we weren't correctly closing
a  file before retrying.  These problems have been fixed in Red Hat Linux 8.0
(although we recently uncovered another bug there (#75377) which I'm hoping to
have a fix for today)
Comment 3 alex.breeze 2002-10-07 17:25:08 EDT
OK, thanks -- I'll look forward to trying 8.0.

Note You need to log in before you can comment on or make changes to this bug.