Bug 75340 - System hangs when loging out gnome2
System hangs when loging out gnome2
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: gdm (Show other bugs)
8.0
i686 Linux
high Severity high
: ---
: ---
Assigned To: Havoc Pennington
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-07 10:02 EDT by Xu Hao Qing
Modified: 2005-10-31 17:00 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-19 19:23:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Xu Hao Qing 2002-10-07 10:02:10 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020809

Description of problem:
System hangs very frequently(but not every time) when loging out gnome2.
Not sure which component it belongs to. I guess it's gdm or xfree86. None of
ctr+alt+backspace, or ctr+alt+F1/F2, or ctr+alt+del can help. I can only cold
reboot.
cpu: PIII 733  Motherboard chips: Intel i815, using the integrated graphic
chips. Xfree86 is configured as "VideoRam 16384(default value), Depth 16, Modes
1024x768"

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1.login gnome2
2.logout
3.
	

Actual Results:  Sometimes system hangs when loging out

Expected Results:  Back to gdm login screen

Additional info:

cpu: PIII 733  
Motherboard chips: Intel i815, using the integrated graphic chips. 
Xfree86 is configured as "VideoRam 16384, Depth 16, Modes 1024x768"
System Ram: 320M
Comment 1 Havoc Pennington 2002-10-07 11:15:38 EDT
Which apps are you running when you log out?
Comment 2 Xu Hao Qing 2002-10-09 08:31:21 EDT
Hi. I finally find that it seems have something with rp-pppoe. To reproduce it:

1. Create an ADSL network device if there isn't one. Let's suppose you name it
MYADSL.
2. Active MYADSL using "System Tools -> Network Device Control"
3. Run Galeon or Mozilla, load www.gnome.org. Note this step is very important.
If you ignore this step, system hange will not occure.
4. Close the browser.
5. Log out gnome desktop.
6. System hanges.

Don't know what components it really belongs to.
Comment 3 Xu Hao Qing 2002-10-19 12:31:02 EDT
Hi. The problem has gone after I updated the system today. The kernel is updated
to 2.4.18-17.8.0
Comment 4 Terry Davis 2002-11-07 13:20:56 EST
I think this to be a problem with gdm.  I experienced the same problem using gdm
and kde as my desktop.  When I added 'DISPLAYMANAGER="KDE"' to
/etc/sysconfig/desktop the problem went away.
Comment 5 Havoc Pennington 2002-12-19 19:23:05 EST
System hangs are inherently kernel or XFree86 bugs. Other programs don't have
access to the hardware that would allow them to hang the system.

Since kernel upgrade fixed the original report, closing. Terry if you can 
reliably reproduce with latest updates then perhaps file a new report, 
ideally with information on your hardware and other configuration details.

Note You need to log in before you can comment on or make changes to this bug.