Bug 75348 - Machine crashes when accessing /proc/scsi/aic7xxx/0
Machine crashes when accessing /proc/scsi/aic7xxx/0
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-07 11:17 EDT by Karl E. Kelley
Modified: 2007-04-18 12:47 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-13 12:58:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karl E. Kelley 2002-10-07 11:17:26 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.0.0-10; Linux)

Description of problem:
When /proc/scsi/aic7xxx/0 is accessed, the machine resets and reboots, with a message about NMI or memory error from the prom just before the grub menu.  This happens only on kernels 2.4.18-10 and 2.4.18-5.  Kernel 2.4.18-4 doesn't exhibit the problem.  The version of the aic7xxx driver is 6.2.6 in both the failing kernels.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.cat /proc/scsi/aic7xxx/0
2.
3.
 

Actual Results:  Machine resets and starts booting again.

Expected Results:  should see contents of /proc/scsi/aic7xxx/0 on screen.  This would be scsi controller configuration/statistics.

Additional info:

The machine in question is a Dell PowerEdge 1300 600Mhz, the SCSI controller in question is an AHA-2940-U2/U2W /7890/7891 (rev 1)
from /proc/pci.  All disks are on that controller.
Comment 1 Justin T. Gibbs 2003-01-10 19:29:02 EST
This is most likely the "proc reads serial eeprom" bug.  What version of
the aic7xxx driver are you using?  This was corrected in 6.2.8.
Comment 2 Karl E. Kelley 2003-01-13 10:41:59 EST
The version of the aic7xxx driver was 6.2.6 in the original report, and I have 
since updated to kernel 2.4.18-17.7.x which has aic7xxx version 6.2.8, and  
I no longer have the problem, for that kernel or the kernel 2.4.18-19.7.x, 
which I am now running. 
 
Kernel 2.4.18-17.7.x came out very shortly after this bug was reported, and I 
should have updated this entry then, but I lost track of it.  Sorry.   
 
 
Comment 3 Justin T. Gibbs 2003-01-13 12:58:11 EST
Resolved in aic7xxx driver version 6.2.8.  Resolution confirmed by
originator.

Note You need to log in before you can comment on or make changes to this bug.