This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 753488 - ibus cannot show the status icon at the session start time in KDE
ibus cannot show the status icon at the session start time in KDE
Status: CLOSED DUPLICATE of bug 727806
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-12 17:29 EST by gcarter
Modified: 2011-11-14 01:51 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-11-14 01:49:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
ibus lack of icon in systray (847.34 KB, image/png)
2011-11-14 00:34 EST, gcarter
no flags Details

  None (edit)
Description gcarter 2011-11-12 17:29:09 EST
Description of problem:  KDE 4.7.2 ibus with installed simpliedfied-chinese-support group is broken.   Was working fine with Fedora 15.


Version-Release number of selected component (if applicable): ibus 1.4.0


How reproducible:
select ibus-setup from the menu, and it seems to startup wonky.

If I run it from the command line, it at least displays its icon in the system try.   If I run it from the systems settings menu it doesn't display its icon.


Steps to Reproduce:
1. login, select input method from KDE menu
2. Starts the input method ibus-setup program.
3. doesn't display its icon in the icon tray.  Try using it with pinyin input, and CTRL SPACE works sporactally.  Mostly never.)
  
Actual results:
Doesn't work.


Expected results:
Should display pinyin characters to pick from when CTRL-SPACE is selected.

Additional info:
KDE 4.7.2 Fedora 16 fresh install.

Installed simplified chinese support group, which is bizarre as it isn't listed in grouplist, but is found in the documentation.

Then installed ibus-pinyin.

Worked fine in Fedora 15.

-gc
Comment 1 fujiwara 2011-11-13 21:23:25 EST
I don't understand what is your problem.

(In reply to comment #0)
> Installed simplified chinese support group, which is bizarre as it isn't listed
> in grouplist, but is found in the documentation.
> 
> Then installed ibus-pinyin.
> 
> Worked fine in Fedora 15.

Which do you mean, you installed ibus-pinyin by manual? or the Fedora installer installed ibus-pinyin with chinese support group?

> 3. doesn't display its icon in the icon tray.  Try using it with pinyin input,
> and CTRL SPACE works sporactally.  Mostly never.)

Can you attach the screenshot in this bugreport?
% gnome-screenshot --delay 10

Do you have ibus-pinyin rpm?

Did you log into the KDE session with zh_CN.UTF-8 locale? You could change the user locale with 'systemsettings' command.
% locale

Did you disable 'Customize active input methods' check button in 'Input Method' tab on ibus-setup GUI?
Comment 2 gcarter 2011-11-14 00:34:12 EST
Created attachment 533433 [details]
ibus lack of icon in systray

Notice the blank spot next to the scissors...normally should have the ibus icon there.

Can only get it too show up if I exit and start it up from the command line.
Comment 3 fujiwara 2011-11-14 01:49:45 EST
OK, I think you cannot show ibus icon when ibus is launched at xdg auto (KDE start time) but you can show the icon when you restart the ibus-daemon.

It's a KDE issue.

*** This bug has been marked as a duplicate of bug 727806 ***

Note You need to log in before you can comment on or make changes to this bug.