Bug 75350 - RFE: redhat-config-securitylevel does not display changes in the firewall rules
RFE: redhat-config-securitylevel does not display changes in the firewall rules
Status: CLOSED DUPLICATE of bug 72678
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-securitylevel (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
: FutureFeature
Depends On:
  Show dependency treegraph
Reported: 2002-10-07 11:36 EDT by Ted Clark
Modified: 2008-05-01 11:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-10-14 12:06:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Ted Clark 2002-10-07 11:36:23 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020809

Description of problem:
redhat-config-securitylevel does not display changes in the firewall rules.  If
I run redhat-config-securitylevel, select "customize", and allow incoming SSH,
it works, but the next time I run redhat-config-securitylevel it displays the
default rules again, even though incoming SSH is working.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Run redhat-config-securitylevel
2. Select "customize" and click the checkbox to allow incoming SSH
3. Save changes and exit; run redhat-config-securitylevel again

Actual Results:  The firewall rules are changed, but the changes are not shown
when redhat-config-securitylevel is run again.

Expected Results:  redhat-config-securitylevel should display the currently set
firewall rules.

Additional info:

Comment 1 Gene Czarcinski 2002-10-07 15:27:15 EDT
You are correct. It does not read the current settings.  This should be changed
to a RFE (Request for Enhancement) to add this capability.
Comment 2 Steve Wardell 2002-10-13 14:22:07 EDT
How is this an RFE an not a bug? It's a usability bug of unexpected behavior.
Comment 3 Gene Czarcinski 2002-10-13 14:30:45 EDT
It is "working as designed" and it is working in the same way as the package
from previous releases that it replaces (lokkit).

I do not disagree that it should read the old configurations but it is currently
designed to start fresh every time.

Changing this from an problem to an enhancement will not do anything to increase
or decrease the chance the Red Hat will fix this.

What we really need is a much more elaborate tool with the capability of
building a real firewall but that would be far more work to create and I suspect
that Red Hat's energies are placed elsewhere.
Comment 4 Brent Fox 2002-10-14 12:12:26 EDT

*** This bug has been marked as a duplicate of 72678 ***

Note You need to log in before you can comment on or make changes to this bug.