Bug 753528 - black screen after idle and no desktop (suspected backlight problem)
black screen after idle and no desktop (suspected backlight problem)
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: kdebase-workspace (Show other bugs)
17
i686 Linux
unspecified Severity high
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-13 01:02 EST by Peter Gückel
Modified: 2012-11-10 13:47 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-10 13:47:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
var/log/messages snippet that might be of interest (5.15 KB, text/plain)
2011-11-13 01:02 EST, Peter Gückel
no flags Details

  None (edit)
Description Peter Gückel 2011-11-13 01:02:06 EST
Created attachment 533331 [details]
var/log/messages snippet that might be of interest

Description of problem:
I have the screensaver kick in after 5 minutes of idle, then powerdevil takes over and blacks out the screen after 10 minutes. Wwhen I wiggle the mouse to resume work, the screen sometimes stays black and I am unable to get a visible desktop, yet the monitor light switches from yellow (as it is in black screen mode) to green (as it is when the monitor is active).

Version-Release number of selected component (if applicable):
kdebase-4.7.3-1.fc16.x86_64

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
I know the computer is running properly and that plasma-desktop has not crashed, etc. I can kill the X server with xtrl-alt-backspace or go to another virtual terminal with ctrl-alt-F2, for example, but the screen remains black. My only recourse is to go to a different virtual terminal, log in and poweroff, in the dark without being able to see anything. Then, I can restart the computer and all is fine.
Comment 1 Peter Gückel 2012-04-13 15:21:04 EDT
I have upgraded to fedora 17 (clean install) and the problem persists. When my laptop is idle for a while, the screen blackens. When I return and move the mouse or press keys to wake it up, the screen remains black. I can see, under rare lighting conditions, that there is a faintly visible image of the desktop and opened windows, but so faint that no test is distinguishable.
Comment 2 Rex Dieter 2012-04-13 15:40:46 EDT
Can you share what video hardware and driver your using?  It may indeed by some bad solid/powerdevil/video-driver interaction.
Comment 3 Peter Gückel 2012-04-14 01:27:07 EDT
OK. I don have the problem on my desktop, so this appears to affect only i686/PAE kernel systems running:

intel video driver
Mobile 915GM/GMS/910GML Express

I noticed that there are entries in the Power Devil settings called Display Brightness and Dim Display. By default, both are enabled.

It kind of sounds like a Dim Display problem, since it won't 'undim', doesn't it?
Comment 4 Peter Gückel 2012-04-18 21:09:21 EDT
It just happened on my desktop computer. I often leave it running and the screensaver kicks in, then the screen blanks, and I have never had a problem with this system,, but just now, I couldn't get the screen back. It was black and I could not see even a shimmer of faint desktop, just blackness.

This computer:

kernel-3.3.2-1.fc17.x86_64
INTEL X3000 (Chipset 965G)
Comment 5 Peter Gückel 2012-04-21 00:13:36 EDT
I suspect the problem on the x86_64 system has something to do with suspend/resume, as it doesn't appear to occur otherwise.

Howver, the problem with the i686 system, as originally described, has nothing to do with suspend/resume, as I always power off the laptop.
Comment 6 Peter Gückel 2012-11-10 13:47:51 EST
Housecleaning.
Will close and reopen if it occurs again.

Note You need to log in before you can comment on or make changes to this bug.