This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 75354 - sysctl variable problem when setting parameters on vlan interfaces
sysctl variable problem when setting parameters on vlan interfaces
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: procps (Show other bugs)
8.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-07 12:11 EDT by Tarhon-Onu Victor
Modified: 2007-04-18 12:47 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-29 07:42:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tarhon-Onu Victor 2002-10-07 12:11:38 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020513

Description of problem:
Sysctl is unable to set up parameters for vlan interfaces. The problem consists
in the separators which are '.' and/or '/'. If in a variable in sysctl.conf are
both present (net.ipv4/ip_forward) sysctl will not warn us. So we will unable to
set (say) rp_filter on eth1.307 vlan interface.
The problem is present to all previous versions of procps, and it can be fixed
quicly if only one of the delimiters is accepted for the same variable.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.create a vlan interface
2.figure out how to write a variable in /etc/sysctl.conf in roder to set
parameters on eth1.307.
3.let me know if you succeed (maybe it's possible, but I found no possibility).
	

Additional info:
Comment 1 Alexander Larsson 2002-10-08 10:28:38 EDT
yeah. That doesn't seem possible.
Unfortunately it also seems hard to fix and stay backwards compat.
Adding a switch is possible, but something else needs to be done for
/etc/sysctl.conf.
Comment 2 Alexander Larsson 2004-02-05 05:44:23 EST
Mass reassign to new owner
Comment 3 Daniel Walsh 2004-03-29 07:42:26 EST
Fixed in procps 3.2.0

Note You need to log in before you can comment on or make changes to this bug.