Bug 75356 - memory leak 2.4.18-10smp
memory leak 2.4.18-10smp
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-07 12:16 EDT by abs01
Modified: 2007-04-18 12:47 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-16 21:41:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description abs01 2002-10-07 12:16:39 EDT
Description of Problem:
Seems like memory is leaking

Version-Release number of selected component (if applicable):
2.4.18-10smp kernel downloaded and installed via redhat's errata as RPM.

How Reproducible:
removed all non redhat 7.3 modules for testing. I can watch memory slowly 
disapeer. Not connected to a network and has the exact same configuration 
as another box using an old redhat 6.2 version with only 1GB RAM. New box 
is 2GB RAM and 2 Zeon processesors. Within a few days memory will be 
consumed and eventually starts to swap to disk. When the system first boots 
it only uses about 175,000 of RAM. Within days the 2,065,140 (2GB) will be 
used and then starts on the Swap memory. After about a week it consumes the 
rest swap. There's no thrashing going on because nothing is running (CPU 
0%), but it will eat up all available memory. Nothing in error log 
indicating a problem either. Memory sticks have been tested.

Steps to Reproduce:
1. 
2. 
3. 

Actual Results:


Expected Results:


Additional Information:
Hardware is Dell 2650 server.

I have also configured another box with a single CPU with an installation 
that is exactly like this Dell. The ONLY difference is the kernel. Same 
version 2.4.18-10, but without SMP and I don't have this problem.
Comment 1 Arjan van de Ven 2002-10-07 12:19:36 EDT
can you post
1) lsmod output
2) a "screenshot" (just c-n-paste) of top after a few days, when typing "M"
(sort by memory usage)
Comment 2 Dave Jones 2003-12-16 21:41:42 EST
closing, no activity in over a year.

Note You need to log in before you can comment on or make changes to this bug.