Bug 75357 - redhat-config-network leaks open files/sockets?
redhat-config-network leaks open files/sockets?
Status: CLOSED DUPLICATE of bug 74989
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network (Show other bugs)
8.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-07 12:25 EDT by Satish Balay
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-07 12:25:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Satish Balay 2002-10-07 12:25:03 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020809

Description of problem:
redhat-config-network crashes if left running for a while (say 1/2 to 1 hour).

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Configure a network connection using redhat-config-network (i've tried both
wired and wireless via pcmcia)
2. Activate the network connection using  redhat-config-network and keep it
running. (i've done reboots between setting & activationg - just to be sure)
3.run the following command in a different window (xterm)
while true; do lsof |grep redhat-co | wc -l ; sleep 5; done
	

All of the above is done as 'root'

Actual Results:
      0
     26
     96
     99
     99
    105
    107
    111
    113
......
......
    573
    585
    589
......
......
   1097
   1103
   1109
   1117
   1117

Until the redhat-config-network crashes with the following error:

Traceback (most recent call last):
  File "/usr/sbin/redhat-config-network", line 774, in update_devicelist
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/Control.py", line
63, in __init__
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/Control.py", line
66, in load
OSError: Too many open files




Expected Results:  No crash.

Additional info:

The files it keeps opening are:


redhat-co  967  root  548u  sock        0,0            774784 can't identify
protocol
redhat-co  967  root  549u  sock        0,0            774785 can't identify
protocol
redhat-co  967  root  550u  sock        0,0            780554 can't identify
protocol
redhat-co  967  root  551u  sock        0,0            780555 can't identify
protocol
redhat-co  967  root  552u  sock        0,0            780559 can't identify
protocol
Comment 1 Harald Hoyer 2002-10-08 10:55:36 EDT

*** This bug has been marked as a duplicate of 74989 ***

Note You need to log in before you can comment on or make changes to this bug.