Bug 753659 - Exception thrown when clicking Back to List after pinning snapshot to template
Exception thrown when clicking Back to List after pinning snapshot to template
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: drift (Show other bugs)
4.2
All All
medium Severity unspecified (vote)
: ---
: JON 3.0.0,RHQ 4.3.0
Assigned To: Jay Shaughnessy
Mike Foley
:
Depends On:
Blocks: jon30-sprint9 707225
  Show dependency treegraph
 
Reported: 2011-11-13 20:53 EST by John Sanda
Modified: 2012-02-07 14:26 EST (History)
2 users (show)

See Also:
Fixed In Version: 4.3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-07 14:23:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Sanda 2011-11-13 20:53:18 EST
Description of problem:
A client-side exception is thrown when I click the "Back to List" button after pinning a snapshot to a template. The exception in the javascript console is:

(-:-) 2011-11-13 20:48:16,551 [TRACE] RPCTracker success: TrackingRequestCallback[id=131, name=DriftGWTService_Proxy.findDriftDefinitionsByCriteria, age=19]
7ABA75261D9DD4BA3331DAB553DCCCD6.cache.html:1919(-:-) 2011-11-13 20:48:16,552 [TRACE] RPCTracker queue depth is 0
7ABA75261D9DD4BA3331DAB553DCCCD6.cache.html:1919(-:-) 2011-11-13 20:48:16,555 [ERROR] At [Sun Nov 13 20:48:16 GMT-500 2011] MessageCenter received: Globally uncaught exception
7ABA75261D9DD4BA3331DAB553DCCCD6.cache.html:1919(-:-) 2011-11-13 20:48:16,567 [WARN ] Globally uncaught exception
7ABA75261D9DD4BA3331DAB553DCCCD6.cache.html:1919java.lang.IndexOutOfBoundsException:
7ABA75261D9DD4BA3331DAB553DCCCD6.cache.html:1919Index: 0, Size: 0
7ABA75261D9DD4BA3331DAB553DCCCD6.cache.html:1919    at Unknown.at com_google_gwt_core_client_impl_StackTraceCreator$CollectorMoz_$collect__Lcom_google_gwt_core_client_impl_StackTraceCreator$CollectorMoz_2Lcom_google_gwt_core_client_JsArrayString_2(Unknown source:0)
7ABA75261D9DD4BA3331DAB553DCCCD6.cache.html:1919    at Unknown.at Object.com_google_gwt_core_client_impl_StackTraceCreator$CollectorMoz_collect__Lcom_google_gwt_core_client_JsArrayString_2 [as collect__Lcom_google_gwt_core_client_JsArrayString_2](Unknown source:0)
7ABA75261D9DD4BA3331DAB553DCCCD6.cache.html:1919    at Unknown.at com_google_gwt_core_client_impl_StackTraceCreator_createStackTrace__Lcom_google_gwt_core_client_JsArrayString_2(Unknown source:0)
7ABA75261D9DD4BA3331DAB553DCCCD6.cache.html:1919    at Unknown.at Object.com_google_gwt_core_client_impl_StackTraceCreator$Collector_fillInStackTrace__Ljava_lang_Throwable_2V [as fillInStackTrace__Ljava_lang_Throwable_2V](Unknown source:0)
7ABA75261D9DD4BA3331DAB553DCCCD6.cache.html:1919    at Unknown.at com_google_gwt_core_client_impl_StackTraceCreator_fillInStackTrace__Ljava_lang_Throwable_2V(Unknown source:0)
7ABA75261D9DD4BA3331DAB553DCCCD6.cache.html:1919    at Unknown.at Object.java_lang_Throwable_fillInStackTrace__Ljava_lang_Throwable_2 [as fillInStackTrace__Ljava_lang_Throwable_2](Unknown source:0)
7ABA75261D9DD4BA3331DAB553DCCCD6.cache.html:1919    at Unknown.at java_lang_Throwable_$$init__Ljava_lang_Throwable_2V(Unknown source:0)
7ABA75261D9DD4BA3331DAB553DCCCD6.cache.html:1919    at Unknown.at java_lang_Throwable_$Throwable__Ljava_lang_Throwable_2Ljava_lang_String_2Ljava_lang_Throwable_2(Unknown source:0)
7ABA75261D9DD4BA3331DAB553DCCCD6.cache.html:1919    at Unknown.at java_lang_Exception_$Exception__Ljava_lang_Exception_2Ljava_lang_String_2Ljava_lang_Exception_2(Unknown source:0)

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Create a user defined template.
2. Create a definition from that template.
3. When the initial snapshot is generated, go to the snapshot view.
4. Click the "Pin to Template" button.
5. Once successful completion of the operation is reported, click "Back to List"
  
Actual results:
Exception is thrown and a blank definitions view is displayed

Expected results:


Additional info:
Comment 1 Jay Shaughnessy 2011-11-22 14:09:55 EST
master commit: 77d9e38f36a5401ecb287ffea42335fc5c9e9463

A subtle issue having to do with the fact that pinning can remove
existing entities therefore invalidating previous views.  A couple of
changes to address this and make things, hopefully, more intuitive:
- When navigating from the definitions list to the initial snapshot the
  "Back to List" button now brings you directly back to the defs list. It
  previously would bring you to the carousel, which was confusing because
  that's not where you navigated from.
- When pinning a snapshot to a template the wizard will, if successful,
  navigate you back to the definitions list view automatically.  This
  higher level view is guaranteed to be valid, and will reflect any new
  pinning-related state changes. On cancel or failure the use will
  remain on the snapshot view.
Comment 2 Sunil Kondkar 2011-11-24 06:28:22 EST
Verified on latest master build#787

Created a drift definition. Navigated to the initial snapshot. Clicking on "Back to List" button navigates directly back to the definitions list.

Clicked on the "Pin to Template" button. Verified that on clicking cancel button, it remains on the snapshot view. On successful completion of the operation, it automatically navigates back to the definitions list view.
Comment 3 Mike Foley 2011-11-28 09:06:59 EST
moving to ON_DEV so it can go to the JON 3 branch.
Comment 4 Jay Shaughnessy 2011-11-28 09:15:48 EST
release_jon3.x commit 21e1403c8ec12b4c5a665231806b3267dc9f58b1

moving back to on_qa for release branch.
Comment 5 Sunil Kondkar 2011-11-29 04:33:15 EST
Verified on build#106 (From https://hudson.qa.jboss.com/hudson/view/JON3%20Core/job/rhq-release/106/)

Verified that clicking "Back to List" button on the initial snapshot navigates directly back to the definitions list.

Verified that on clicking cancel button on the 'Pin Drift Definition Template Wizard', it remains on the snapshot view. On successful completion of the
operation, it automatically navigates back to the definitions list view.

Marking as verified.
Comment 6 Mike Foley 2012-02-07 14:23:53 EST
changing status of VERIFIED BZs for JON 2.4.2 and JON 3.0 to CLOSED/CURRENTRELEASE
Comment 7 Mike Foley 2012-02-07 14:26:13 EST
marking VERIFIED JON 3 bugs to CLOSED/CURRENTRELEASE

Note You need to log in before you can comment on or make changes to this bug.