Bug 75366 - Mouse configuration with PS/2 and USB only uses USB
Mouse configuration with PS/2 and USB only uses USB
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2002-10-07 14:23 EDT by Horst H. von Brand
Modified: 2007-04-18 12:47 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2003-01-26 01:30:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Horst H. von Brand 2002-10-07 14:23:46 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
This is a Toshiba notebook with builtin PS/2 mouse (2 buttons). I have a 
3-button USB mouse, which works fine.

I installed telling it USB, 3-button. During installation _both_ mice worked. In
the installed system only the USB mouse works. I tried reconfiguring for a PS/2
mouse, same result.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.Configure PS/2 mouse (USB plugged in)

Actual Results:  PS/2 doesn work, even after reiniting XFree86 and gpm.

Expected Results:  Both mice working (hopefully...)

Additional info:
Comment 1 Mike A. Harris 2002-10-08 01:01:42 EDT
If it worked during installation, that means XFree86 works with both
just fine, so it isn't an XFree86 bug.  I'm betting that the config
used during install, and the one generated for usage on the system
by anaconda/redhat-config-xfree86 are different.  It's probably a
config tool glitch.

Can you try running "redhat-config-xfree86 --reconfig" and see if
you can get it to work again?

I've CC'd our tool maintainers.
Comment 2 Mike A. Harris 2002-10-08 03:41:09 EDT
s/tool/config tool/
Comment 3 Horst H. von Brand 2002-10-09 09:20:59 EDT
Yep, the suggestion of reconfiguring XFree86 did work. Thanks!

Just the video card here is a Trident CyberBlade XPAi1 (rev 82), which XFree86
insists on handling as a generic VESA card. The CyberBlade XP driver does work
fine (and gets 1024x768 24 bits on this screen, as it should).
Comment 4 Alexander Larsson 2002-10-09 09:52:00 EDT
But the initial (with mouse not working) configuration was written by the installer?
Comment 5 Horst H. von Brand 2002-10-09 11:50:44 EDT
The configuration was written by the update from rawhide to RH 8.0, AFAIU. It
might have been old (from RH 7.3 perhaps).
Comment 6 Mike A. Harris 2003-01-26 01:30:44 EST
Closing bug as NOTABUG since you've indicated that reconfiguration fixed it
so was is likely just a config glitch/inconsistency of some kind.

Note You need to log in before you can comment on or make changes to this bug.