Bug 753675 - DBus will not allow selinux-alerted actions even in selinux permissive mode.
Summary: DBus will not allow selinux-alerted actions even in selinux permissive mode.
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libselinux
Version: 6.1
Hardware: All
OS: Linux
urgent
high
Target Milestone: rc
: ---
Assignee: Miroslav Grepl
QA Contact: Eduard Benes
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-11-14 04:38 UTC by Rob K
Modified: 2018-12-09 16:46 UTC (History)
12 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2014-10-14 06:41:05 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1469 normal SHIPPED_LIVE libselinux bug fix update 2014-10-14 01:10:46 UTC

Description Rob K 2011-11-14 04:38:06 UTC
Description of problem:

when running virt-manager of ssh/X11, dbus encounters an selinux avc and errors out, despite selinux being in permissive mode.

Version-Release number of selected component (if applicable):
dbus-1.2.24-5.el6_1.x86_64
libselinux-2.0.94-5.el6.x86_64


How reproducible:
Set selinux=permissive, reboot, watch any attempt to run X11 over ssh.

Steps to Reproduce:
1. login, run virt-manager
2. see window complaining that virt-manager can't talk to gconf
  
Actual results:
virt-manager --debug shows the following:
dbus_bus_get(): An SELinux policy
prevents this sender from sending this message to this recipient
(rejected message had interface "org.freedesktop.DBus" member "Hello"
error name "(unset)" destination "org.freedesktop.DBus

Expected results:
virt-manager works of ssh/X11

Additional info:
setting selinux=disabled works fine, but I don't want to run in this mannner.

Comment 2 RHEL Product and Program Management 2011-11-14 05:08:31 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.

Comment 28 Rob K 2013-02-06 02:01:14 UTC
Still not workin'. We've just turned off selinux to get our stuff working, which is kind of heart-breaking but what else can we do?

Comment 39 Rob K 2014-06-24 23:53:51 UTC
Having some trouble working out why this is taking three years to fix. Am I missing something?

Comment 50 errata-xmlrpc 2014-10-14 06:41:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1469.html


Note You need to log in before you can comment on or make changes to this bug.