Bug 75370 - Missing auth_ldap module in httpd distribution
Missing auth_ldap module in httpd distribution
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: httpd (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
Brian Brock
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-07 15:14 EDT by Need Real Name
Modified: 2007-04-18 12:47 EDT (History)
2 users (show)

See Also:
Fixed In Version: 2.0.45-4
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-18 15:04:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-10-07 15:14:09 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.8 [en] (X11; U; Linux 2.4.18-ac3 i686)

Description of problem:
With the release of RedHat 8.0, auth_ldap was removed. Apache 2.x ships with
auth_ldap as a common module now. However, the rpm supplied does not include
this module.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Compare RHOS 7.2, 7.3, 8.0, particularly for rpm package: auth_ldap
2. RHOS 7.2 ( auth_ldap-1.4.8-3 ), RHOS 7.3 ( auth_ldap-1.6.0-4 ), RHOS 8.0 (
missing )
	

Actual Results:  auth_ldap is missing from the RedHat 8.0 distribution.

Expected Results:  Functionality of auth_ldap package from RHOS 7.x is
maintained, either by inclusion as a package added to httpd, or internal 
to the httpd distribution.

Additional info:
Comment 1 Need Real Name 2002-10-07 17:52:30 EDT
Upon further examination, I noticed that mod_auth_ldap is *not* distributed with
apache <= 2.0.40. It was added @ Version 2.0.41. When rebuilding in relation to
BUG # 74882, perhaps you could add the following to configure during the httpd
build?

"--enable-ldap --with-ldap --enable-auth-ldap"

TIA
Comment 2 Nick Urbanik 2002-10-10 09:55:21 EDT
I really want this too.  I built a new package with http_ldap from CVS; I hope
Red Hat will include it as an errata before my laboratory exercise with my students!
Comment 3 Joe Orton 2003-05-18 15:04:00 EDT
mod_auth_ldap (and mod_ldap) are included in httpd-2.0.45-4.
Comment 4 David Schroeder 2003-08-27 23:29:17 EDT
I have been waiting for the auth_ldap module to be included in the httpd 
package for since RH7.3 too.

I have just installed RH Enterprise Linux 3 AS Beta 2 and while the LDAP 
modules can be included by rebuilding and adding the configure options, is 
there any reason why they can't be built into future distributions.

The version I am using is httpd-2.0.46-13.ent.i386.rpm
Comment 5 Joe Orton 2003-08-28 02:10:37 EDT
The Taroon beta includes mod_authz_ldap as a separate package, since it is
better tested than the LDAP packages included in httpd.  (and more advanced)

Note You need to log in before you can comment on or make changes to this bug.