Bug 75372 - System stop loading on first CD with errors.
System stop loading on first CD with errors.
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
: 82239 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-07 16:07 EDT by Need Real Name
Modified: 2007-04-18 12:47 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-07 16:08:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda trace of problem (69.26 KB, text/plain)
2002-10-07 16:08 EDT, Need Real Name
no flags Details
anaconda dump - gui install (69.46 KB, text/plain)
2003-01-21 12:51 EST, marc wissman
no flags Details

  None (edit)
Description Need Real Name 2002-10-07 16:07:06 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; SunOS 5.8 sun4u)

Description of problem:
Tried installing from four different CD 1 disk. During the installation process
the system failed three times. An dialog box was presented each time. The
files/trace information was written to a floppy. Some of the information is
listed below. The entire file is available. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Started Installation
2.Installation was progressing through first CD

	

Actual Results:  Error dialog box appeared on the screen

Expected Results:  Finished disk one and requested disk 2

Additional info:

Traceback (innermost last):
  File "/usr/bin/anaconda", line 633, in ?
    intf.run(id, dispatch, configFileData)
  File "/usr/lib/anaconda/gui.py", line 353, in run
    self.icw.run (self.runres, configFileData)
  File "/usr/lib/anaconda/gui.py", line 814, in run
    mainloop ()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2676, in mainloop
    _gtk.gtk_main()
  File "/usr/lib/anaconda/gui.py", line 529, in handleRenderCallback
    self.currentWindow.renderCallback()
  File "/usr/lib/anaconda/iw/progress_gui.py", line 135, in renderCallback
    self.intf.icw.nextClicked()
  File "/usr/lib/anaconda/gui.py", line 417, in nextClicked
    self.dispatch.gotoNext()
  File "/usr/lib/anaconda/dispatch.py", line 144, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 209, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/packages.py", line   File
"/usr/lib/anaconda/image.py", line 86, in getFilename
    isys.umount("/mnt/source")
  File "/usr/lib/anaconda/isys.py", line 171, in umount
    rc = _isys.umount(what)
SystemError: (16, 'Device or resource busy')

Local variables in innermost frame:
what: /mnt/source
removeDir: 1
 
...

THE LAST LINES OF THE FILE CREATED

Installing xml-common-0.6.3-9.
Installing docbook-dtds-1.0-8.
Installing openjade-1.3.1-4.
Comment 1 Need Real Name 2002-10-07 16:08:02 EDT
Created attachment 79244 [details]
anaconda trace of problem
Comment 2 Jeremy Katz 2002-10-07 17:15:15 EDT
Please check your meida following the instructions at
http://rhlinux.redhat.com/anaconda/mediacheck.html.  The most common cause of
this problem is media problems or media incompatibility with your CDROM drive
Comment 3 marc wissman 2003-01-21 12:48:58 EST
I have also noticed this same error. It fails while loading, still on the 1st
CD. I ran the media check and it passed.
It seems that the system is trying to unmount the CD so that it can request
the next CD. Note that this fails while starting to load "openjade-1.3.1-4"
which is physically located on Disk 2. I have tried two sets of disks. From
either IDE or SCSI DVDRoms. Targeting either IDE or SCSI HDD's. My error
is identical no matter what setup I tried. I also noticed that someone
posted this same bug (#161 in insight) but it was closed due to being
submitted to the wrong area.

other bugs that look the same or similar are:
58879 - cant go on to 3rd disk
64539 - cant go on to 2nd disk 
64866 - cant go on to 2nd disk - closed due to inactivity
64969 - same error (from line numbers) but in german! - closed due to inactivity
Comment 4 marc wissman 2003-01-21 12:51:27 EST
Created attachment 89478 [details]
anaconda dump - gui install
Comment 5 Jeremy Katz 2003-01-22 01:02:31 EST
*** Bug 82239 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.