Bug 753760 - environment-modules does not append default MANPATH
Summary: environment-modules does not append default MANPATH
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: environment-modules
Version: 16
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Orion Poplawski
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 758486 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-11-14 12:19 UTC by Vedran Miletić
Modified: 2011-12-10 19:55 UTC (History)
6 users (show)

Fixed In Version: environment-modules-3.2.9c-1.fc16
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-10 19:55:12 UTC
Type: ---


Attachments (Terms of Use)

Description Vedran Miletić 2011-11-14 12:19:30 UTC
[vedranm@inf2 ~]$ man ls
No manual entry for ls
[vedranm@inf2 ~]$ echo $MANPATH 
/usr/share/man/mpich2
[vedranm@inf2 ~]$ rpm -qa | grep mpich2
mpich2-1.4.1p1-1.fc16.x86_64
mpich2-devel-1.4.1p1-1.fc16.x86_64

Comment 1 Vedran Miletić 2011-11-16 12:53:30 UTC
Jussi Lehtola, could you please help with this?

Comment 2 Susi Lehtola 2011-11-16 13:04:32 UTC
That's a good question, since MANPATH overrides the default configuration. Maybe MANPATH should be set so that it also includes the default man dir /usr/share/man.

This is probably also an issue with openmpi et al.

Comment 3 Vedran Miletić 2011-11-16 13:21:33 UTC
Thanks for your response.

From what I see on the other machine without mpich2 and openmpi, default configuration for $MANPATH is unset. Not sure if that's intended.

On this machine I have in /etc:

[vedranm@inf2 ~]$ find /etc | xargs grep MANPATH 2> /dev/null
(...)
/etc/modulefiles/openmpi-x86_64:prepend-path            MANPATH         /usr/share/man/openmpi-x86_64
/etc/modulefiles/mpich2-x86_64:# Define prefix so PATH and MANPATH can be updated.
/etc/modulefiles/mpich2-x86_64:prepend-path  MANPATH       /usr/share/man/mpich2
/etc/bash_completion.d/man:        manpath=$MANPATH

Could it be a bash or environment-modules issue then?

Comment 4 Susi Lehtola 2011-11-16 15:42:29 UTC
from the man man page:
       MANPATH
              If $MANPATH is set, its value is used as the path to search  for
              manual pages.

By default nothing uses MANPATH, instead the configuration is (AFAIK) in /etc/man_db.conf. However, this approach is not usable for the environment modules approach.

I don't know what would be the best approach: change the system-wide shell defaults to set MANPATH to the system directories (so that the MPI stuff would work without any changes), or modify each of the MPI packages and add the system man directory to the environment modules.

Comment 5 Mamoru TASAKA 2011-11-29 02:16:09 UTC
cc-ing to Orion, the maintainer of environment-modules

Manpath issue v.s. environment-modules:
bug 756951
bug 753760 (this)
bug 753920

Comment 6 Orion Poplawski 2011-11-29 02:38:19 UTC
Yup, this is a modules issue.  I've reported upstream.  I've been unable to create a fix due to some internal changes in the code that I don't understand.

Comment 7 Mamoru TASAKA 2011-11-29 03:20:27 UTC
One of the quickest workarounds may be:
https://lists.sdsc.edu/pipermail/npaci-rocks-discussion/2009-May/039520.html

Comment 8 Fedora Update System 2011-11-29 17:57:52 UTC
environment-modules-3.2.9c-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/environment-modules-3.2.9c-1.fc16

Comment 9 Fedora Update System 2011-11-29 17:58:00 UTC
environment-modules-3.2.9c-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/environment-modules-3.2.9c-1.fc15

Comment 10 Fedora Update System 2011-11-30 01:52:46 UTC
Package environment-modules-3.2.9c-1.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing environment-modules-3.2.9c-1.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-16561/environment-modules-3.2.9c-1.fc16
then log in and leave karma (feedback).

Comment 11 Deji Akingunola 2011-12-05 14:55:59 UTC
*** Bug 758486 has been marked as a duplicate of this bug. ***

Comment 12 Jouni Väliaho 2011-12-07 09:45:43 UTC
(In reply to comment #10)
> # su -c 'yum update --enablerepo=updates-testing environment-modules-3.2.9c-1.fc16'

This update fixed the problem for me.

Thanks!

Comment 13 Fedora Update System 2011-12-10 19:55:12 UTC
environment-modules-3.2.9c-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 14 Fedora Update System 2011-12-10 19:55:49 UTC
environment-modules-3.2.9c-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.