Bug 753836 - [abrt] kernel: BUG: unable to handle kernel NULL pointer dereference at 0000000000000008 (after hibernate)
[abrt] kernel: BUG: unable to handle kernel NULL pointer dereference at 00000...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
abrt_hash:ee1ddf7613e36293d84d78c97b2...
:
Depends On:
Blocks: kernel_hibernate
  Show dependency treegraph
 
Reported: 2011-11-14 11:21 EST by Evgeniy
Modified: 2012-05-14 13:57 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-14 13:57:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: smolt_data (3.70 KB, text/plain)
2011-11-14 11:21 EST, Evgeniy
no flags Details

  None (edit)
Description Evgeniy 2011-11-14 11:21:29 EST
libreport version: 2.0.6
abrt_version:   2.0.4.981
cmdline:        BOOT_IMAGE=/boot/vmlinuz-3.1.0-7.fc16.x86_64 root=UUID=3382ed73-86f1-4b2c-a79f-2b28aad4c721 ro LANG=ru_RU.UTF-8 rd.md=0 rd.lvm=0 rd.dm=0 quiet noirqdebug rhgb rd.luks=0 KEYTABLE=ru
comment:        Launch notebook from hibernate.
kernel:         undefined
reason:         BUG: unable to handle kernel NULL pointer dereference at 0000000000000008
time:           Mon Nov 14 20:17:14 2011

smolt_data:     Binary file, 3792 bytes

backtrace:
:BUG: unable to handle kernel NULL pointer dereference at 0000000000000008
:IP: [<ffffffff8122f6d9>] __list_add+0x14/0x7f
:PGD aaad7067 PUD a6de9067 PMD 0 
:Oops: 0000 [#1] SMP 
:CPU 3 
:Modules linked in: ppdev parport_pc lp parport fuse nfs fscache auth_rpcgss nfs_acl lockd nf_conntrack_netbios_ns nf_conntrack_broadcast nf_conntrack_ipv4 nf_defrag_ipv4 ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 xt_state nf_conntrack ip6table_filter ip6_tables uvcvideo videodev media v4l2_compat_ioctl32 arc4 ath9k snd_hda_codec_hdmi mac80211 snd_hda_codec_conexant ath9k_common ath9k_hw ath cfg80211 snd_hda_intel snd_hda_codec snd_hwdep snd_seq snd_seq_device snd_pcm snd_timer snd joydev microcode soundcore snd_page_alloc iTCO_wdt jmb38x_ms iTCO_vendor_support memstick sunrpc asus_laptop jme mii sparse_keymap serio_raw intel_ips rfkill i2c_i801 uinput sdhci_pci sdhci mmc_core i915 drm_kms_helper drm i2c_algo_bit i2c_core video [last unloaded: scsi_wait_scan]
:Pid: 7788, comm: pm-hibernate Not tainted 3.1.0-7.fc16.x86_64 #1 ASUSTeK Computer Inc. K52F/K52F
:RIP: 0010:[<ffffffff8122f6d9>]  [<ffffffff8122f6d9>] __list_add+0x14/0x7f
:RSP: 0018:ffff8800b0f35e38  EFLAGS: 00010246
:RAX: 0000000000000000 RBX: 0000000000000000 RCX: 0000000000000000
:RDX: 0000000000000000 RSI: ffff8800aef8bb90 RDI: ffff88004b977770
:RBP: ffff8800b0f35e58 R08: ffff8800b64d63f0 R09: 0000000000000008
:R10: 0000000000000008 R11: 0000000000000246 R12: ffff8800aef8bb90
:R13: ffff88004b977770 R14: 0000000000000000 R15: ffff8800b0f35f50
:FS:  00007fb4ad229700(0000) GS:ffff8800b64c0000(0000) knlGS:0000000000000000
:CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
:CR2: 0000000000000008 CR3: 00000000abfc0000 CR4: 00000000000006e0
:DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
:DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400
:Process pm-hibernate (pid: 7788, threadinfo ffff8800b0f34000, task ffff88005a444590)
:Stack:
: ffff8800b64d63f0 ffff88004b9776c0 ffff8800aef8ba80 ffff88004b97771c
: ffff8800b0f35e68 ffffffff811392cd ffff8800b0f35e98 ffffffff811395b2
: 0000000000000001 ffff8800aef8ba80 ffff88004b9776c0 0000000000a0be00
:Call Trace:
: [<ffffffff811392cd>] list_add+0x11/0x13
: [<ffffffff811395b2>] __d_instantiate+0x48/0x79
: [<ffffffff811397ec>] d_instantiate+0x40/0x5c
: [<ffffffff81130f3f>] create_write_pipe+0x12d/0x1ad
: [<ffffffff8113107c>] do_pipe_flags+0x32/0xf4
: [<ffffffff8113115a>] sys_pipe2+0x1c/0x5c
: [<ffffffff811311aa>] sys_pipe+0x10/0x12
: [<ffffffff814bc482>] system_call_fastpath+0x16/0x1b
:Code: ad de 48 b9 00 02 20 00 00 00 ad de 48 89 13 48 89 4b 08 5e 5b 5d c3 55 48 89 e5 41 55 49 89 fd 41 54 49 89 f4 53 48 89 d3 41 50 <4c> 8b 42 08 49 39 f0 74 20 49 89 d1 48 89 f1 48 c7 c2 e7 30 7e 
:RIP  [<ffffffff8122f6d9>] __list_add+0x14/0x7f
: RSP <ffff8800b0f35e38>
:CR2: 0000000000000008

event_log:
:2011-11-14-20:19:06> Smolt profile successfully saved
:2011-11-14-20:20:19> Submitting oops report to http://submit.kerneloops.org/submitoops.php
:2011-11-14-20:21:23  Kernel oops has not been sent due to Couldn't connect to server
:2011-11-14-20:21:23* (exited with 1)
Comment 1 Evgeniy 2011-11-14 11:21:32 EST
Created attachment 533564 [details]
File: smolt_data
Comment 2 Dave Jones 2012-03-22 13:10:40 EDT
[mass update]
kernel-3.3.0-4.fc16 has been pushed to the Fedora 16 stable repository.
Please retest with this update.
Comment 3 Dave Jones 2012-03-22 13:13:15 EDT
[mass update]
kernel-3.3.0-4.fc16 has been pushed to the Fedora 16 stable repository.
Please retest with this update.
Comment 4 Dave Jones 2012-03-22 13:22:41 EDT
[mass update]
kernel-3.3.0-4.fc16 has been pushed to the Fedora 16 stable repository.
Please retest with this update.
Comment 5 Josh Boyer 2012-03-28 14:03:21 EDT
[Mass hibernate bug update]

Dave Airlied has found an issue causing some corruption in the i915 fbdev after a resume from hibernate.  I have included his patch in this scratch build:

http://koji.fedoraproject.org/koji/taskinfo?taskID=3940545

This will probably not solve all of the issues being tracked at the moment, but it is worth testing when the build completes.  If this seems to clear up the issues you see with hibernate, please report your results in the bug.

Note You need to log in before you can comment on or make changes to this bug.